Android Eclipse:Unsupported major.minor version 52.0

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/u010635353/article/details/53407119

本文不讲原理,不通篇大论,只是记录一个知识点,方便以后查找.

最近一直在用Android Studio开发,然后以前一个Eclipse的项目需要做一次升级。打开了尘封已久的Eclipse – Run As Android Application,突然发现运行报错了。Unsupported major.minor version 52.0。MD,明明都是没问题的,然后在网上查了一下资料,问题得以解决,记录一下。

网上有人说是JDK版本的问题,升一下JDK就好了,但是我的JDK版本一直都是1.7,所以原因不可能是JDK。后来想到,AS环境和Eclipse环境公用一个SDK,既然是通过操作AS导致Eclipse不可用,那么就一定是SDK的问题了。

解决问题如下:

是因为SDK tools 有冲突。打开SDK Manager。

这里写图片描述

把24的tools删掉,重新运行Eclipse,编译通过,运行成功。

展开阅读全文

没有更多推荐了,返回首页