题目:Parencodings
Description:
Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways:
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence).
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence).
Following is an example of the above encodings:
S (((()()()))) P-sequence 4 5 6666 W-sequence 1 1 1456
InPut:
The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.
OutPut:
The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.
Samples Input:
2 6 4 5 6 6 6 6 9 4 6 6 6 6 8 9 9 9
Samples OutPut:
1 1 1 4 5 6 1 1 2 4 5 1 1 3 9
Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string.
答案:
#include<stdio.h>
#include<stdlib.h>
#include<iostream>
using namespace std;
/*
* Author: Chenhan
* 思路:
* 每个右括号匹配的左括号一定是离他最近的还没有被匹配上的左括号
* 计算前后两个输入值的差为m,这个差表示这两个右括号之间的左括号的数目
* 两个索引的差为n,表示中间隔了多少个左括号
* 如果m >= n,表示可以匹配成功,匹配的左括号就在这两个右括号之间
* 否则,表示这之间没有匹配的左括号,说明目标左括号在这之前,offset需要+1,
* 因为这个左括号和另一个右括号相匹配,且目标左括号和这个右括号之间一定间隔了这个和其他右括号匹配的左括号
* */
void handlePS(int num, int *src, int *res)
{
res[0] = 1;//初始化为1,是因为本身自己对应的右括号就算1
for(int i = 1; i < num; i++){
int offset = 1;
for(int j = i - 1; j >= 0; j--){
if(src[i] - src[j] >= i - j){
res[i] = offset;
break;
}
offset++;
if(j == 0)
{
res[i] = offset;
}
}
}
}
void printResult(int num, int *res){
for(int i = 0; i < num - 1; i++){
cout<<res[i]<<" ";
}
cout<<res[num - 1];
}
void parsePSIntoWS()
{
int src[40] = {0};
int res[40] = {0};
int num;
cin >> num;
if(num < 1) return;
for(int i = 0; i < num; i++){
cin>>src[i];
}
handlePS(num, src, res);
printResult(num, res);
}
int main(){
int caseNum;
cin >> caseNum;
for(int i = 0; i< caseNum - 1; i++){
parsePSIntoWS();
cout<<endl;
}
parsePSIntoWS();
}