堆的实现 2196. Nuanran's Idol II

堆用数组实现,时间复杂度为O(logn),如果进一本书就排序一次的话时间复杂度很高。


You have known that nuanran is a loyal fan of Kelly from the last contest. For this reason, nuanran is interested in collecting pictures of Kelly. Of course, he doesn't like each picture equally. So he gives each picture a score which is a positive integer. And the larger the score is, the more he likes that picture. Nuanran often goes to buy new pictures in some shops to increase his picture collection.

Sometimes nuanran's friends ask him for Kelly's picture and he will choose the picture having the smallest score. Because he has many pictures, this is a boring task. Can you help him again?

Input

For each test case, the first line gives an integer n (1 ≤ n ≤ 100000). Then n lines follow, each line has one of the following two formats.

  • "B S". Denoting nuanran buys a new picture and S is the score of that picture.
  • "G". Denoting nuanran gives a picture to his friends.

    The input is terminated when n=0.

    Output

    For each giving test case, you should output the score of the picture nuanran gives to his friends.

    Sample Input

    8
    B 20
    B 10
    G
    B 9
    G
    B 100
    B 25
    G
    0
    

    Sample Output

    10
    9
    20
    
    #include<iostream>
    #include<cstring>
    using namespace std;
    int a[100001],len=0;//len为堆的尾部
    int leftchild(int n)
    {
    	return n*2;
    }
    int rightchild(int n)
    {
    	return n*2+1;
    }
    int parent(int n)
    {
    	return n/2;
    }
    int gettop()
    {
    	return a[1];
    }
    void heapfy(int t)
    {
    	int l,r,m;
    	l=leftchild(t);
    	r=rightchild(t);
    	m=t;
    	if(l<len&&a[m]>a[l])
    		m=l;
    	if(r<len&&a[m]>a[r])
    		m=r;//寻找最小值下标
    	if(m!=t)
    	{
    		swap(a[t],a[m]);
    		heapfy(m);
    	}
    	return;
    }
    void insert(int t)
    {
    	a[len]=t;
    	int p=parent(len);
    	int q=len;
    	while(a[p]>a[q]&&p>0)
    	{
    		swap(a[p],a[q]);
    		q=p;
    		p=parent(p);
    	}
    	len++;
    	return ;
    }
    void pop()
    {
    	if(len==0)
    		return;
    	len--;
    	//cout<<a[1];
    	a[1]=a[len];
    	a[len]=0;
    	heapfy(1);
    	return;
    }
    int main()
    {
    	int n,s;
    	char c;
    	while(cin>>n&&n)
    	{
    		len=1;
    		memset(a,-1,sizeof(a));
    		while(n--){
    			cin>>c;
    			if(c=='B')
    			{
    				cin>>s;
    				insert(s);
    			}
    			else
    			{
    				cout<<gettop()<<endl;
    				pop();
    			}
    		}
    	}
    	return 0;
    }


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值