堆的实现 2196. Nuanran's Idol II

堆用数组实现,时间复杂度为O(logn),如果进一本书就排序一次的话时间复杂度很高。


You have known that nuanran is a loyal fan of Kelly from the last contest. For this reason, nuanran is interested in collecting pictures of Kelly. Of course, he doesn't like each picture equally. So he gives each picture a score which is a positive integer. And the larger the score is, the more he likes that picture. Nuanran often goes to buy new pictures in some shops to increase his picture collection.

Sometimes nuanran's friends ask him for Kelly's picture and he will choose the picture having the smallest score. Because he has many pictures, this is a boring task. Can you help him again?

Input

For each test case, the first line gives an integer n (1 ≤ n ≤ 100000). Then n lines follow, each line has one of the following two formats.

  • "B S". Denoting nuanran buys a new picture and S is the score of that picture.
  • "G". Denoting nuanran gives a picture to his friends.

    The input is terminated when n=0.

    Output

    For each giving test case, you should output the score of the picture nuanran gives to his friends.

    Sample Input

    8
    B 20
    B 10
    G
    B 9
    G
    B 100
    B 25
    G
    0
    

    Sample Output

    10
    9
    20
    
    #include<iostream>
    #include<cstring>
    using namespace std;
    int a[100001],len=0;//len为堆的尾部
    int leftchild(int n)
    {
    	return n*2;
    }
    int rightchild(int n)
    {
    	return n*2+1;
    }
    int parent(int n)
    {
    	return n/2;
    }
    int gettop()
    {
    	return a[1];
    }
    void heapfy(int t)
    {
    	int l,r,m;
    	l=leftchild(t);
    	r=rightchild(t);
    	m=t;
    	if(l<len&&a[m]>a[l])
    		m=l;
    	if(r<len&&a[m]>a[r])
    		m=r;//寻找最小值下标
    	if(m!=t)
    	{
    		swap(a[t],a[m]);
    		heapfy(m);
    	}
    	return;
    }
    void insert(int t)
    {
    	a[len]=t;
    	int p=parent(len);
    	int q=len;
    	while(a[p]>a[q]&&p>0)
    	{
    		swap(a[p],a[q]);
    		q=p;
    		p=parent(p);
    	}
    	len++;
    	return ;
    }
    void pop()
    {
    	if(len==0)
    		return;
    	len--;
    	//cout<<a[1];
    	a[1]=a[len];
    	a[len]=0;
    	heapfy(1);
    	return;
    }
    int main()
    {
    	int n,s;
    	char c;
    	while(cin>>n&&n)
    	{
    		len=1;
    		memset(a,-1,sizeof(a));
    		while(n--){
    			cin>>c;
    			if(c=='B')
    			{
    				cin>>s;
    				insert(s);
    			}
    			else
    			{
    				cout<<gettop()<<endl;
    				pop();
    			}
    		}
    	}
    	return 0;
    }


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值