BFS 3517. The longest athletic track

解题思路:

先随便确定一个顶点,则从该顶点广搜到的最远的点一定是该图的一个起始点,则再从该点出发,广搜。


After a long time of algorithm training, we want to hold a running contest in our beautiful campus. Because all of us are curious about a coders's fierce athletic contest,so we would like a more longer athletic track so that our contest can last more .


In this problem, you can think our campus consists of some vertexes connected by roads which are undirected and make no circles, all pairs of the vertexes in our campus are connected by roads directly or indirectly, so it seems like a tree, ha ha.


We need you write a program to find out the longest athletic track in our campus. our athletic track may consist of several roads but it can't use one road more than once.

Input

*Line 1: A single integer: T represent the case number T <= 10
For each case
*Line1: N the number of vertexes in our campus 10 <= N <= 2000
*Line2~N three integers a, b, c represent there is a road between vertex a and vertex b with c meters long
1<= a,b <= N,  1<= c <= 1000;

Output

For each case only one integer represent the longest athletic track's length

Sample Input

1
7
1 2 20
2 3 10
2 4 20
4 5 10
5 6 10
4 7 40

Sample Output

80

#include<iostream>
#include<cstring>
using namespace std;
const int num=2000;
int n,visit[num],map[num][num],x,y,maxx;
struct
{
	int a,sum;
}q[num];
int bfs(int begin)
{
	int max=0,top=1,k;
	memset(visit,0,sizeof(visit));
	visit[begin]=1;
	q[0].a=begin;
	q[0].sum=0;
	maxx=0;
	for(int i=0;i<top;i++)
	{
		int temp=q[i].a;//i为当前点在栈中所处位置
		for(int j=1;j<=n;j++)//j为从当前点出发要入栈的点的num
		{
			if(map[temp][j]!=-1&&!visit[j])
			{
				visit[j]=1;
				q[top].a=j;
				//top++;
				q[top].sum=q[i].sum+map[temp][j];
				if(q[top].sum>maxx)
				{
					maxx=q[top].sum;
					k=j;
				}
				top++;
			}
		}
	}
	return k;
}
int main()
{
	int t,a,b,c;
	cin>>t;
	while(t--)
	{
		cin>>n;
		memset(map,-1,sizeof(map));
		for(int i=0;i<n-1;i++)
		{
			cin>>a>>b>>c;
			map[a][b]=map[b][a]=c;
		}
		int v=bfs(1);
		v=bfs(v);
		cout<<maxx<<endl;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值