2547. Subsequence

终于知道错哪儿了。。。。

刚开始用for循环,对于每个i,从i开始,加每个元素,如果大于等于sum,则记录长度与l比较,想了好久,觉得这种最原始的方法没有错,但是后来发现:

如果从某个起点开始加,加到大于等于s的数后,若这个子序列的前端有些数可以被剪掉,这样就会有更小的长度了,刚开始忽略了这种情况。


A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Many test cases will be given. The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals.

For each the case the program has to print the result on separate line.

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3
#include<iostream>
using namespace std;
int a[100001];
int main()
{
	int N,n,s,l,sum,l1;
	cin>>N;
	while(N--)
	{
		cin>>n>>s;
		for(int i=0;i<n;i++)
			cin>>a[i];
		l=100001;
		l1=0;
		sum=0;
		int i,j=0;
		for( i=0;i<n;i++)
		{
			sum=sum+a[i];
			if(sum>=s)
			{
				while(sum>=s)
				{
					sum=sum-a[j];
					j++;
				}
				l1=i-j+2;
				if(l1<l)
					l=l1;
			}
		}
		if(l==100001)
			cout<<"0"<<endl;
		else
		cout<<l<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值