hdu 4930 Fighting the Landlords

Fighting the Landlords

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 480    Accepted Submission(s): 163


Problem Description
Fighting the Landlords is a card game which has been a heat for years in China. The game goes with the 54 poker cards for 3 players, where the “Landlord” has 20 cards and the other two (the “Farmers”) have 17. The Landlord wins if he/she has no cards left, and the farmer team wins if either of the Farmer have no cards left. The game uses the concept of hands, and some fundamental rules are used to compare the cards. For convenience, here we only consider the following categories of cards:

1.Solo: a single card. The priority is: Y (i.e. colored Joker) > X (i.e. Black & White Joker) > 2 > A (Ace) > K (King) > Q (Queen) > J (Jack) > T (10) > 9 > 8 > 7 > 6 > 5 > 4 > 3. It’s the basic rank of cards.

2.Pair : two matching cards of equal rank (e.g. 3-3, 4-4, 2-2 etc.). Note that the two Jokers cannot form a Pair (it’s another category of cards). The comparison is based on the rank of Solo, where 2-2 is the highest, A-A comes second, and 3-3 is the lowest.

3.Trio: three cards of the same rank (e.g. 3-3-3, J-J-J etc.). The priority is similar to the two categories above: 2-2-2 > A-A-A > K-K-K > . . . > 3-3-3.

4.Trio-Solo: three cards of the same rank with a Solo as the kicker. Note that the Solo and the Trio should be different rank of cards (e.g. 3-3-3-A, 4-4-4-X etc.). Here, the  Kicker’s rank is irrelevant to the comparison, and the Trio’s rank determines the priority. For example, 4-4-4-3 > 3-3-3-2.

5.Trio-Pair : three cards of the same rank with a Pair as the kicker (e.g. 3-3- 3-2-2, J-J-J-Q-Q etc.). The comparison is as the same as Trio-Solo, where the Trio is the only factor to be considered. For example,4-4-4-5-5 > 3-3-3-2-2. Note again, that two jokers cannot form a Pair.

6.Four-Dual: four cards of the same rank with two cards as the kicker. Here,  it’s allowed for the two kickers to share the same rank. The four same cards dominates the comparison: 5-5-5-5-3-4 > 4-4-4-4-2-2.

In the categories above, a player can only beat the prior hand using of the same category but not the others. For example, only a prior Solo can beat a Solo while a Pair cannot. But there’re exceptions:

7.Nuke: X-Y (JOKER-joker). It can beat everything in the game.

8.Bomb: 4 cards of the same rank. It can beat any other category except Nuke or another Bomb with a higher rank. The rank of Bombs follows the rank of individual cards: 2-2-2-2 is the highest and 3-3-3-3 is the lowest.

Given the cards of both yours and the next player’s, please judge whether you have a way to play a hand of cards that the next player cannot beat you  in this round.If you no longer have cards after playing, we consider that he cannot beat you either. You may see the sample for more details.
 

Input
The input contains several test cases. The number of test cases T (T<=20) occurs in the first line of input.

Each test case consists of two lines. Both of them contain a string indicating your cards and the next player’s, respectively. The length of each string doesn’t exceed 17, and  each single card will occur at most 4 times totally on two players’ hands except that the two Jokers each occurs only once.
 

Output
For each test case, output Yes if you can reach your goal, otherwise output No.
 

Sample Input
  
  
4 33A 2 33A 22 33 22 5559T 9993
 

Sample Output
  
  
Yes No Yes Yes
 

Author
BUPT
 

Source
 



代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

struct node
{
    int Solo[20],num_Solo;
    int Pair[20],num_Pair;
    int Trio[20],num_Trio;
    int Four[20],num_Four;
    int Nuke;
}n[2];


void work(char s[],int d)
{
    int len=strlen(s);
    memset(&n[d],0,sizeof(n[0]));
    n[d].num_Solo=len;
    for(int i=0;i<len;i++)
    {
       if(s[i]>='3'&&s[i]<='9')
       n[d].Solo[s[i]-'2']++;
       else if(s[i]=='T') n[d].Solo[8]++;
       else if(s[i]=='J') n[d].Solo[9]++;
       else if(s[i]=='Q') n[d].Solo[10]++;
       else if(s[i]=='K') n[d].Solo[11]++;
       else if(s[i]=='A') n[d].Solo[12]++;
       else if(s[i]=='2') n[d].Solo[13]++;
       else if(s[i]=='X') n[d].Solo[14]++;
       else if(s[i]=='Y') n[d].Solo[15]++;
    }

    for(int i=1;i<=13;i++)
    {
        if(n[d].Solo[i]>=2) n[d].Pair[i]++,n[d].num_Pair++;
        if(n[d].Solo[i]>=3) n[d].Trio[i]++,n[d].num_Trio++;
        if(n[d].Solo[i]>=4) n[d].Four[i]++,n[d].num_Four++;
    }

    if(n[d].Solo[14]&&n[d].Solo[15]) n[d].Nuke=1;

    return;
}

bool solve()
{   //考虑双王的情况
    if(n[0].Nuke) return true;
    //一次能出去
    if(n[0].num_Solo==1) return true;
    if(n[0].num_Pair&&n[0].num_Solo==2) return true;
    if(n[0].num_Trio&&n[0].num_Solo==3) return true;
    if(n[0].num_Four&&n[0].num_Solo==4) return true;
    if(n[0].num_Trio&&n[0].num_Solo==4) return true;
    if(n[0].num_Trio&&n[0].num_Pair>=2&&n[0].num_Solo==5) return true;
    if(n[0].num_Four&&n[0].num_Solo==6) return true;
    
    //如果我不能一次出去,对方有最大的牌,无论我出什么都不行
    if(n[1].Nuke) return false;

    //考虑我有的牌的类型,对方没有的情况
    //考虑对的情况
    if(n[0].num_Pair&&!n[1].num_Pair) return true;
    //考虑三个的情况
    if(n[0].num_Trio&&!n[1].num_Trio) return true;
    //考虑炸的情况
    if(n[0].num_Four&&!n[1].num_Four) return true;
    //考虑三带一的情况
    if(n[0].num_Trio&&n[0].num_Solo>=4&&n[1].num_Solo<4&&!n[1].num_Four) return true;
    //考虑三带二的情况
    if(n[0].num_Trio&&n[0].num_Pair>=2&&n[1].num_Solo<5&&!n[1].num_Four) return true;
    //考虑四带二的情况
    if(n[0].num_Four&&n[0].num_Solo>=6&&n[1].num_Solo<6&&!n[1].num_Four) return true;


    //考虑我有的牌的类型,对方也有的情况
    int l=0,r=0;
    //考虑出一张牌的情况
    for(int i=1;i<=15;i++)
    {
        if(n[0].Solo[i]) l=i;
        if(n[1].Solo[i]) r=i;
    }
    if(l>=r&&!n[1].num_Four) return true;
    //考虑出两张牌的情况
    if(n[0].num_Pair)
    {
        l=0;r=0;
        for(int i=1;i<=13;i++)
        {
            if(n[0].Pair[i]) l=i;
            if(n[1].Pair[i]) r=i;
        }
        if(l>=r&&!n[1].num_Four) return true;
    }
    //考虑出三张牌的情况
    if(n[0].num_Trio)
    {
        l=0;r=0;
        for(int i=1;i<=13;i++)
        {
            if(n[0].Trio[i]) l=i;
            if(n[1].Trio[i]) r=i;
        }
        if(l>=r&&!n[1].num_Four) return true;
    }
    //考虑出四张牌的情况
    if(n[0].num_Four)
    {
        l=0;r=0;
        for(int i=1;i<=13;i++)
        {
            if(n[0].Four[i]) l=i;
            if(n[1].Four[i]) r=i;
        }
        if(l>=r) return true;
    }
    return false;
}

int main()
{
    char s1[25],s2[25];
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s%s",s1,s2);
        work(s1,0);
        work(s2,1);
        if(solve())
            printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值