hdu 4930 Fighting the Landlords (模拟)

Fighting the Landlords

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 160    Accepted Submission(s): 52


Problem Description
Fighting the Landlords is a card game which has been a heat for years in China. The game goes with the 54 poker cards for 3 players, where the “Landlord” has 20 cards and the other two (the “Farmers”) have 17. The Landlord wins if he/she has no cards left, and the farmer team wins if either of the Farmer have no cards left. The game uses the concept of hands, and some fundamental rules are used to compare the cards. For convenience, here we only consider the following categories of cards:

1.Solo: a single card. The priority is: Y (i.e. colored Joker) > X (i.e. Black & White Joker) > 2 > A (Ace) > K (King) > Q (Queen) > J (Jack) > T (10) > 9 > 8 > 7 > 6 > 5 > 4 > 3. It’s the basic rank of cards.

2.Pair : two matching cards of equal rank (e.g. 3-3, 4-4, 2-2 etc.). Note that the two Jokers cannot form a Pair (it’s another category of cards). The comparison is based on the rank of Solo, where 2-2 is the highest, A-A comes second, and 3-3 is the lowest.

3.Trio: three cards of the same rank (e.g. 3-3-3, J-J-J etc.). The priority is similar to the two categories above: 2-2-2 > A-A-A > K-K-K > . . . > 3-3-3.

4.Trio-Solo: three cards of the same rank with a Solo as the kicker. Note that the Solo and the Trio should be different rank of cards (e.g. 3-3-3-A, 4-4-4-X etc.). Here, the  Kicker’s rank is irrelevant to the comparison, and the Trio’s rank determines the priority. For example, 4-4-4-3 > 3-3-3-2.

5.Trio-Pair : three cards of the same rank with a Pair as the kicker (e.g. 3-3- 3-2-2, J-J-J-Q-Q etc.). The comparison is as the same as Trio-Solo, where the Trio is the only factor to be considered. For example,4-4-4-5-5 > 3-3-3-2-2. Note again, that two jokers cannot form a Pair.

6.Four-Dual: four cards of the same rank with two cards as the kicker. Here,  it’s allowed for the two kickers to share the same rank. The four same cards dominates the comparison: 5-5-5-5-3-4 > 4-4-4-4-2-2.

In the categories above, a player can only beat the prior hand using of the same category but not the others. For example, only a prior Solo can beat a Solo while a Pair cannot. But there’re exceptions:

7.Nuke: X-Y (JOKER-joker). It can beat everything in the game.

8.Bomb: 4 cards of the same rank. It can beat any other category except Nuke or another Bomb with a higher rank. The rank of Bombs follows the rank of individual cards: 2-2-2-2 is the highest and 3-3-3-3 is the lowest.

Given the cards of both yours and the next player’s, please judge whether you have a way to play a hand of cards that the next player cannot beat you  in this round.If you no longer have cards after playing, we consider that he cannot beat you either. You may see the sample for more details.
 

Input
The input contains several test cases. The number of test cases T (T<=20) occurs in the first line of input.

Each test case consists of two lines. Both of them contain a string indicating your cards and the next player’s, respectively. The length of each string doesn’t exceed 17, and  each single card will occur at most 4 times totally on two players’ hands except that the two Jokers each occurs only once.
 

Output
For each test case, output Yes if you can reach your goal, otherwise output No.
 

Sample Input
  
  
4 33A 2 33A 22 33 22 5559T 9993
 

Sample Output
  
  
Yes No Yes Yes
 

题意:两个人打扑克,规则参照斗地主。问先手能否一次出完牌或者出的第一手牌让对方无牌可出!!

模拟就是了:

#include"stdio.h"
#include"string.h"
#define N 20
#define M 100
int a[N],b[N],n,m;
char s[N];
int max(int a,int b)
{
    return a>b?a:b;
}
void inti(char*s,int f)
{
    int i,t;
    for(i=0;s[i]!='\0';i++)
    {
        if(s[i]>='3'&&s[i]<='9')
        {
            t=s[i]-'0'-2;
        }
        else if(s[i]=='T')
            t=8;
        else if(s[i]=='J')
            t=9;
        else if(s[i]=='Q')
            t=10;
        else if(s[i]=='K')
            t=11;
        else if(s[i]=='A')
            t=12;
        else if(s[i]=='2')
            t=13;
        else if(s[i]=='X')
            t=14;
        else if(s[i]=='Y')
            t=15;
        if(f==1)
            a[t]++;
        else
            b[t]++;
    }
}
int escape()
{
    int i;
    if(n==1)         //枚举我方有几张牌,能否一次出完
        return 1;
    if(n==2)          
    {
        int n2=0;
        for(i=1;i<14;i++)
            if(a[i]==2)
                n2++;
        if(n2==1)
            return 1;
    }
    if(n==3)
    {
        int n3=0;
        for(i=1;i<14;i++)
            if(a[i]==3)
                n3++;
        if(n3==1)
            return 1;
    }
    if(n==4)
    {
        int n3=0;
        for(i=1;i<14;i++)
        {
            if(a[i]>=3)
                n3++;
        }
        if(n3==1)
            return 1;
    }
    if(n==5)
    {
        int n2=0,n3=0;
        for(i=1;i<14;i++)
        {
            if(a[i]==3)
                n3++;
            if(a[i]==2)
                n2++;
        }
        if(n2==1&&n3==1)
            return 1;
    }
    if(n==6)
    {
        int n4=0;
        for(i=1;i<14;i++)
        {
            if(a[i]==4)
                n4++;
        }
        if(n4==1)
            return 1;
    }
    return 0;
}
int beat()
{
    int i,j;
    if(a[14]==1&&a[15]==1)
        return 1;
    if(b[14]==1&&b[15]==1)
        return 0;           //对方有王炸
    for(i=13;i>0;i--)
        if(a[i]==4)
            break;
    for(j=13;j>0;j--)
        if(b[j]==4)
            break;
    if(j>0)        //对方有炸弹,
    {
        if(i>=j)
            return 1;
        else
            return 0;
    }      
    if(n>=5)             //下面就是对方没有炸弹,
    {                    //出3带2,下面3带1就不用枚举了
        int a3,a2,b3,b2;
        a3=a2=b3=b2=0;
        for(i=13;i>0;i--)
        {
            if(a[i]==3)
                a3=max(a3,i);
            if(a[i]==2)
                a2=max(a2,i);
        }
        for(j=13;j>0;j--)
        {
            if(b[j]==3)
                b3=max(b3,j);
            if(b[j]==2)
                b2=max(b2,j);
        }
        if(a3!=0&&a2!=0)
        {
            if(a3>=b3||b2==0)
                return 1;
        }
    }              //四张牌只能是炸弹或者3带1,
    if(n>=3)
    {
        for(i=13;i>0;i--)
            if(a[i]>=3)
                break;
        for(j=13;j>0;j--)
            if(b[j]>=3)
                break;
        if(i!=0)
        {
            if(i>=j)
                return 1;
        }
    }
    if(n>=2)
    {
        for(i=13;i>0;i--)
            if(a[i]>=2)
                break;
        for(j=13;j>0;j--)
            if(b[j]>=2)
                break;
        if(i!=0)
        {
            if(i>=j)
                return 1;
        }
    }
    if(n>=1)            //出一张牌 无炸弹
    {
        for(i=15;i>0;i--)
            if(a[i])
                break;
        for(j=15;j>0;j--)
            if(b[j])
                break;
        if(i>=j)
            return 1;
    }
    return 0;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%s",s);
        n=strlen(s);         
        inti(s,1);
        scanf("%s",s);
        m=strlen(s);
        inti(s,2);
        if(escape())        //能否一次把牌出完
        {
            printf("Yes\n");
            continue;
        }
        if(beat())        //第一手牌无敌
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值