PAT:B1033. 旧键盘打字(16/20)

旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及坏掉的那些键,打出的结果文字会是怎样?

输入格式:

输入在2行中分别给出坏掉的那些键、以及应该输入的文字。其中对应英文字母的坏键以大写给出;每段文字是不超过105个字符的串。可用的字符包括字母[a-z, A-Z]、数字0-9、以及下划线“_”(代表空格)、“,”、“.”、“-”、“+”(代表上档键)。题目保证第2行输入的文字串非空。

注意:如果上档键坏掉了,那么大写的英文字母无法被打出。

输出格式:

在一行中输出能够被打出的结果文字。如果没有一个字符能被打出,则输出空行。

输入样例:
7+IE.
7_This_is_a_test.
输出样例:

_hs_s_a_tst


#include <stdio.h>
#include <cstring>
using namespace std;
bool state[50] = { false };

int main() {
	char str1[50];
	scanf("%s", str1);
	//printf("%d\n", strlen(str1));
	for (int i = 0; i < strlen(str1); i++)
	{
		if (str1[i]>='a'&&str1[i]<='z'){
			state[str1[i] - 'a'] = true;
		}else if (str1[i]>='A'&&str1[i]<='Z')
		{
			state[str1[i] - 'A'] = true;
		}
		else if(str1[i]>='0'&&str1[i]<='9')
        {
            state[str1[i]-'0'+31]=true;
        }
		else if(str1[i]=='_')
		{
			state[str1[i] - '_' + 26] = true;
		}
		else if (str1[i] == ',') {
			state[str1[i] - ',' + 27] = true;
		}
		else if (str1[i] == '.') {
			state[str1[i] - '.' + 28] = true;
		}
		else if (str1[i] == '-') {
			state[str1[i] - '-' + 29] = true;
		}
		else
		{
			state[30] = true;
		}
	}
	char temp;
	char str2[100010];
	scanf("%s",str2);
	for(int i=0;i<=strlen(str2);i++){
        temp=str2[i];
		if ((temp>='a'&&temp<='z')&&(state[temp-'a']==true))
		{
			continue;
		}
		else if((temp>='A'&&temp<='Z')&&(state[temp-'A']==true))
		{
			continue;
		}
		else if ((temp >= 'A'&&temp <= 'Z') && (state[30] == true))
		{
			continue;
		}
		else if (temp == '_'&&state[temp - '_' + 26] == true)
		{
			continue;
		}
		else if (temp == ','&&state[temp - ',' + 27] == true)
		{
			continue;
		}
		else if (temp == '.'&&state[temp - '.' + 28] == true)
		{
			continue;
		}
		else if (temp == '-'&&state[temp - '-' + 29] == true)
		{
			continue;
		}
		else if(temp>='0'&&temp<='9'&&state[temp-'0'+31]==true)
        {
            continue;
        }
		else
		{
			printf("%c", temp);
			continue;
		}
	}
	printf("\n");
	return 0;
}

有一个1′运行错误,和一个3′运行超时。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值