二分图最大匹配--poj2536

Language:
Gopher II
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5822 Accepted: 2428

Description

The gopher family, having averted the canine threat, must face a new predator.  

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

Input

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output

Output consists of a single line for each case, giving the number of vulnerable gophers.

Sample Input

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

Sample Output

1

题意:有很多洞和地鼠,如果地鼠在s秒内不能到洞里就会被吃掉,问被吃掉的最少的数目。
思路:二分图最大匹配,以地鼠和洞为节点建图,得出最多可以逃出的数目。

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
struct node
{
    double x,y;
} gopher[105],hole[105];
int con[105][105];
bool vis[105];
int pre[105];
int n,m,s,v;
bool dist(node a,node b)
{
    double p=sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    if(p<=s*v)
        return 1;
    return 0;
}
bool dfs(int u)
{
    for(int i=1;i<=m;i++)
    {
        if((!vis[i])&&con[u][i])
        {
            vis[i]=1;
            if(pre[i]==0||dfs(pre[i]))
            {
                pre[i]=u;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(cin>>n>>m>>s>>v)
    {
        memset(con,0,sizeof(con));
        memset(pre,0,sizeof(pre));
        for(int i=1; i<=n; i++)
            cin>>gopher[i].x>>gopher[i].y;
        for(int i=1; i<=m; i++)
            cin>>hole[i].x>>hole[i].y;
        int dis=s*v;
        for(int i=1; i<=n; i++)
            for(int j=1; j<=m; j++)
            {
                if(dist(gopher[i],hole[j]))
                    con[i][j]=1;
            }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(dfs(i))
                ++ans;
        }
        cout<<n-ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值