特殊dfs--poj2718

Language:
Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2768 Accepted: 792

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0.  

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28

要想差值尽量小,两个数的位数最多相差一(偶数时相等,奇数个时相差一)
1.dfs搜索。
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
int a[12],b[12],n,ans;
bool vis[12];

void solve(int aa)
{
    int len=0;
    int bb=0;
    for(int i=0;i<n;i++)
        if(!vis[i])//如果被分割的这个点没有访问过
            b[len++]=a[i],bb=bb*10+a[i];//就存入b数组里
    if(b[0]!=0||len==1)
        ans=min(ans,abs(aa-bb));
    while(next_permutation(b,b+len))//这里是从开妹那里学来的,这个stl的含义是才生成从b到b+len的序列的全排列
    {
        bb=0;
        for(int i=0;i<len;i++)//针对每一种排列进行运算,然后比较求出,最小
            bb=bb*10+b[i];
        if(b[0]!=0||len==1)
            ans=min(ans,abs(aa-bb));
    }
}
void dfs(int k,int r)
{
    if(k==n/2)//想要差距最小,位数看就要最接近,所以要对半分
    {
        solve(r);
        return;
    }
    for(int i=0;i<n;i++)
    {
        if(!vis[i])
        {
            if(a[i]==0&&k==0&&n>3)//多位的时候,不允许有前导0
               continue;
            vis[i]=true;
            dfs(k+1,r*10+a[i]);
            vis[i]=false;
        }
    }
}
int main()
{
    int T;
    for(scanf("%d ",&T);T;T--)
    {
        n=0;
        char ch;
        while((ch=getchar())!='\n')
        {
            if(ch==' ')
                continue;
            a[n++]=ch-'0';
        }
        ans=inf;
        memset(vis,false,sizeof(vis));
        dfs(0,0);
        printf("%d\n",ans);
    }
    return 0;
}

2.下面是没用dfs的。
#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
const int INF=100000000;
int a[15];
int ans,n;
void solve()
{
    while(a[0]==0)
        next_permutation(a,a+n);
    int i=0,ans=INF;
    int mid=(n+1)/2;
    do
    {
        if(a[mid]!=0)
        {
            int x=a[0],y=a[mid];
            for(int i=1; i<mid; i++)
                x=x*10+a[i];
            for(int i=mid+1; i<n; i++)
                y=y*10+a[i];
            ans=min(ans,abs(x-y));
        }
    }
    while(next_permutation(a,a+n));
    cout<<ans<<endl;

}
int main()
{
    //freopen("in.txt","r",stdin);
    int t;
    cin>>t;
    getchar();
    while(t--)
    {
        char x;
        int i=0,m;
        while((x=getchar())!='\n')
        {
            if(x!=' ')
                a[i++]=x-'0';
        }
        n=i;
        if(n==1)
        {
            cout<<a[0]<<endl;
            continue;
        }
        if(n==2)
        {
            cout<<abs(a[0]-a[1])<<endl;
            continue;
        }
        solve();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值