线段树(需要维护左半部分与右半部分)-poj3368

Language:
Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11921 Accepted: 4360

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1, ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

线段树写法,代码如下:
#include<iostream>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<cmath>
#include<climits>
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm>
typedef long long LL;
using namespace std;
struct node
{
    int s,t,lnum,rnum,mnum;
} tree[400010];
int N,Q;
int d[100110];
void build(int s,int t,int num)
{
    tree[num].s=s;
    tree[num].t=t;
    if(s==t)
    {
        tree[num].lnum=tree[num].rnum=tree[num].mnum=1;
        return ;
    }
    int mid=(tree[num].s+tree[num].t)>>1;
    build(s,mid,num<<1);
    build(mid+1,t,(num<<1)+1);
    int tmp=0;
    if(d[tree[num<<1].t]==d[tree[(num<<1)+1].s])
        tmp=tree[num<<1].rnum+tree[(num<<1)+1].lnum;
    tree[num].mnum=max(max(tree[num<<1].mnum,tree[(num<<1)+1].mnum),tmp);
    tree[num].lnum=tree[num<<1].lnum;
    if(tree[num<<1].lnum==mid-s+1&&d[tree[num<<1].t]==d[tree[(num<<1)+1].s])
        tree[num].lnum+=tree[(num<<1)+1].lnum;
    tree[num].rnum=tree[(num<<1)+1].rnum;
    if(tree[(num<<1)+1].rnum==t-mid&&d[tree[(num<<1)+1].s]==d[tree[num<<1].t])
        tree[num].rnum+=tree[num<<1].rnum;

}
int find1(int a,int b,int num)
{
    if(a==tree[num].s&&tree[num].t==b)
        return tree[num].mnum;
    int mid=(tree[num].s+tree[num].t)>>1;
    if(a>mid)
        return find1(a,b,(num<<1)+1);
    else if(b<=mid)
        return find1(a,b,num<<1);
    else
    {
        int l=find1(a,mid,num<<1);
        int r=find1(mid+1,b,(num<<1)+1);
        int a3=0;
         if(d[tree[num*2].t]==d[tree[num*2+1].s])
            a3=min(tree[num*2].rnum,mid-a+1)+min(tree[num*2+1].lnum,b-mid);
        return max(max(l,r),a3);
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    int a,b;
    while(cin>>N)
    {
        if(!N)
            break;
        cin>>Q;
        for(int i=1; i<=N; i++)
            scanf("%d",&d[i]);
        build(1,N,1);
        for(int i=0; i<Q; i++)
        {
            scanf("%d%d",&a,&b);
            cout<<find1(a,b,1)<<endl;
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值