LCA+poj1470

13 篇文章 0 订阅

Language:
Closest Common Ancestors
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 15187 Accepted: 4844

Description

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)

Input

The data set, which is read from a the std input, starts with the tree description, in the form:  

nr_of_vertices  
vertex:(nr_of_successors) successor1 successor2 ... successorn  
...
where vertices are represented as integers from 1 to n ( n <= 900 ). The tree description is followed by a list of pairs of vertices, in the form:  
nr_of_pairs  
(u v) (x y) ...  

The input file contents several data sets (at least one).  
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.

Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times  
For example, for the following tree:  

Sample Input

5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
      (2 3)
(1 3) (4 3)

Sample Output

2:1
5:5

Hint

Huge input, scanf is recommended.


裸地LCA,注意输入的格式

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=910;
vector<int> g[maxn];

vector<int> qu[maxn];
int ans[maxn];
int in[maxn];
int n;
int pre[maxn],ance[maxn],vis[maxn];

int find(int x)
{
    if(pre[x]==x)return x;
    return pre[x]=find(pre[x]);
}
void unite(int a,int b)
{
    int x=find(a);
    int y=find(b);
    pre[y]=x;
}

void LCA(int u)
{
    pre[u]=u;
    ance[find(u)]=u;
    int len=g[u].size();
    for(int i=0;i<len;i++)
    {
        int v=g[u][i];
        LCA(v);
        unite(u,v);
        ance[find(v)]=u;
    }
    vis[u]=true;
    len=qu[u].size();
    for(int i=0;i<len;i++)
    {
        int v=qu[u][i];
        if(vis[v])
            ans[find(v)]++;
    }
}

void init()
{
    for(int i=0;i<=n;i++)
    {
        g[i].clear();
        qu[i].clear();
    }
    memset(in,0,sizeof(in));
    memset(vis,0,sizeof(vis));
    memset(ans,0,sizeof(ans));
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        init();
        for(int i=1;i<=n;i++)
        {
            int v,num;
            scanf("%d:(%d)",&v,&num);
            for(int j=0;j<num;j++)
            {
                int x;
                scanf("%d",&x);
                g[v].push_back(x);
                in[x]++;
            }
        }
        int q,a,b,c;
        scanf("%d",&q);
        while(q--)
        {
            while(getchar()!='(');
            scanf("%d%d",&a,&b);
            qu[a].push_back(b);
            qu[b].push_back(a);
        }
        while(getchar()!=')');
        int s;
        for(int i=1;i<=n;i++)
            if(!in[i]){s=i;break;}
        LCA(s);
        for(int i=1;i<=n;i++)
            if(ans[i])printf("%d:%d\n",i,ans[i]);
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值