Trie树+并查集+欧拉回路poj2513

Language:
Colored Sticks
Time Limit: 5000MS Memory Limit: 128000K
Total Submissions: 30307 Accepted: 8007

Description

You are given a bunch of wooden sticks. Each endpoint of each stick is colored with some color. Is it possible to align the sticks in a straight line such that the colors of the endpoints that touch are of the same color?

Input

Input is a sequence of lines, each line contains two words, separated by spaces, giving the colors of the endpoints of one stick. A word is a sequence of lowercase letters no longer than 10 characters. There is no more than 250000 sticks.

Output

If the sticks can be aligned in the desired way, output a single line saying Possible, otherwise output Impossible.

Sample Input

blue red
red violet
cyan blue
blue magenta
magenta cyan

Sample Output

Possible

题意:有很多木棒,每根木棒两端有颜色,颜色相同的可以接起来,问可不可以一笔画

思路:就跟单词接龙一样,每种颜色看成一个节点,每根木棒那个看成一条边,问题就转化成了是否存在欧拉回路。对单词进行编号时用Trie进行优化,并查集判断是不是联通

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=250010;
char s1[100],s2[100];
int in[maxn*2];
int pre[maxn*2],id,num;

struct node
{
    node *next[30];
    int val;
    node(){memset(next,0,sizeof(next));val=0;}
};
struct TREE
{
    node *root;
    void clear(){root=new node();}
    int idx(char x){return x-'a';}
    int insert(char *s)
    {
        int n=strlen(s);
        node *p=root;
        for(int i=0;i<n;i++)
        {
            int c=idx(s[i]);
            if(!p->next[c])
                p->next[c]=new node();
            p=p->next[c];
        }
        if(!p->val)p->val=num++;
        return p->val;
    }
}tree;
int find(int x)
{
    if(x==pre[x])return x;
    return pre[x]=find(pre[x]);
}
void unite(int a,int b)
{
    int x=find(a),y=find(b);
    if(x==y)return;
    pre[y]=x;
}
int main()
{
    memset(in,0,sizeof(in));
    num=1;
    tree.clear();
    for(int i=0;i<maxn*2;i++)pre[i]=i;
    while(scanf("%s%s",s1,s2)!=EOF)
    {
        int x=tree.insert(s1);
        int y=tree.insert(s2);
        in[x]++,in[y]++;
        unite(x,y);
    }
    int cnt=0;
    for(int i=1;i<num;i++)
        if(pre[i]==i)cnt++;
    if(cnt>1){printf("Impossible\n");return 0;}
    cnt=0;
    for(int i=1;i<num;i++)
        if(in[i]%2)cnt++;
    if(cnt==2||cnt==0)printf("Possible\n");
    else printf("Impossible\n");
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值