主席树(2012多校联合)hdu4348

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
BestCoder官方群:385386683 欢迎加入~
寻人启事:2014级新生看过来!

To the moon

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2516    Accepted Submission(s): 498


Problem Description
Background
To The Moon is a independent game released in November 2011, it is a role-playing adventure game powered by RPG Maker.
The premise of To The Moon is based around a technology that allows us to permanently reconstruct the memory on dying man. In this problem, we'll give you a chance, to implement the logic behind the scene.

You‘ve been given N integers A [1], A [2],..., A [N]. On these integers, you need to implement the following operations:
1.  C l r d: Adding a constant d for every {A i  | l <= i <= r}, and increase the time stamp by 1, this is the only operation that will cause the time stamp increase.  
2.  Q l r: Querying the current sum of {A i  | l <= i <= r}.
3.  H l r t: Querying a history sum of {A i  | l <= i <= r} in time t.
4.  B t: Back to time t. And once you decide return to a past, you can never be access to a forward edition anymore.
.. N, M ≤ 10 5, |A [i]| ≤ 10 9, 1 ≤ l ≤ r ≤ N, |d| ≤ 10 4  .. the system start from time 0, and the first modification is in time 1, t ≥ 0, and won't introduce you to a future state.
 

Input
n m
A 1  A 2  ... A n
... (here following the m operations. )
 

Output
... (for each query, simply print the result. )
 

Sample Input
      
      
10 5 1 2 3 4 5 6 7 8 9 10 Q 4 4 Q 1 10 Q 2 4 C 3 6 3 Q 2 4 2 4 0 0 C 1 1 1 C 2 2 -1 Q 1 2 H 1 2 1
 

Sample Output
      
      
4 55 9 15 0 1
 

Author
HIT
 

Source

思路:主席树保存过去的状态,注释sum和add的更新

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=200010;
const int maxm=maxn*50;
int N,M,num;
int a[maxn];
LL sum[maxm],add[maxm];
int T[maxm],lson[maxm],rson[maxm];

int build(int l,int r)
{
    int root=num++;
    sum[root]=add[root]=0;
    if(l==r)
    {
        sum[root]=a[l];
        return root;
    }
    int mid=(l+r)>>1;
    lson[root]=build(l,mid);
    rson[root]=build(mid+1,r);
    sum[root]=sum[lson[root]]+sum[rson[root]];
    return root;
}
void maintain(int newroot,int root)
{
    lson[newroot]=lson[root];
    rson[newroot]=rson[root];
    add[newroot]=add[root];
    sum[newroot]=sum[root];
}
int update(int root,int l,int r,int q1,int q2,int d)
{
    int newroot=num++;
    maintain(newroot,root);
    sum[newroot]+=(min(q2,r)-max(q1,l)+1)*(LL)d;
    if(q1<=l&&r<=q2)
    {
        add[newroot]+=d;
        return newroot;
    }
    int mid=(l+r)>>1;
    if(q1<=mid)lson[newroot]=update(lson[root],l,mid,q1,q2,d);
    if(q2>mid)rson[newroot]=update(rson[root],mid+1,r,q1,q2,d);
    return newroot;

}
LL query(int root,int l,int r,int q1,int q2)
{
    LL ans=(min(q2,r)-max(q1,l)+1)*add[root];
    if(q1<=l&&r<=q2)return sum[root];
    int mid=(l+r)>>1;
    if(q1<=mid)ans+=query(lson[root],l,mid,q1,q2);
    if(q2>mid)ans+=query(rson[root],mid+1,r,q1,q2);
    return ans;
}
int main()
{
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        for(int i=1;i<=N;i++)scanf("%d",&a[i]);
        int cur=0;
        num=0;
        T[0]=build(1,N);
        while(M--)
        {
            char op[5];
            int l,r,d,t;
            scanf("%s%d",op,&l);
            if(op[0]=='C')
            {
                scanf("%d%d",&r,&d);
                T[cur+1]=update(T[cur],1,N,l,r,d);
                cur++;
            }
            else if(op[0]=='Q')
            {
                scanf("%d",&r);
                printf("%I64d\n",query(T[cur],1,N,l,r));
            }
            else if(op[0]=='H')
            {
                scanf("%d%d",&r,&t);
                printf("%I64d\n",query(T[t],1,N,l,r));
            }
            else cur=l;
        }
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值