HUST - 1017
Description
There is an N*M matrix with only 0s and 1s, (1 <= N,M <= 1000). An exact cover is a selection of rows such that every column has a 1 in exactly one of the selected rows. Try to find out the selected rows.
Input
There are multiply test cases. First line: two integers N, M; The following N lines: Every line first comes an integer C(1 <= C <= 100), represents the number of 1s in this row, then comes C integers: the index of the columns whose value is 1 in this row.
Output
First output the number of rows in the selection, then output the index of the selected rows. If there are multiply selections, you should just output any of them. If there are no selection, just output "NO".
Sample Input 6 7 3 1 4 7 2 1 4 3 4 5 7 3 3 5 6 4 2 3 6 7 2 2 7 Sample Output 3 2 4 6 |
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=1010;
const int maxm=1010;
const int maxnode=100010;
int N,M;
struct DLX
{
int n,m,size;
int U[maxnode],D[maxnode],R[maxnode],L[maxnode];
int H[maxn],S[maxm];
int row[maxnode],col[maxnode];
int ansd,ans[maxn];
void init(int N,int M)
{
n=N,m=M;
ansd=0;
for(int i=0;i<=m;i++)
{
S[i]=0;
U[i]=D[i]=i;
L[i]=i-1;
R[i]=i+1;
}
L[0]=m,R[m]=0;
size=m;
memset(H,-1,sizeof(H));
}
void Link(int r,int c)
{
++S[col[++size]=c];
row[size]=r;
D[size]=D[c];
U[size]=c;
U[D[c]]=size;
D[c]=size;
if(H[r]<0)H[r]=R[size]=L[size]=size;
else
{
R[size]=R[H[r]];
L[size]=H[r];
L[R[H[r]]]=size;
R[H[r]]=size;
}
}
void remove(int c)
{
L[R[c]]=L[c],R[L[c]]=R[c];
for(int i=D[c];i!=c;i=D[i])
{
for(int j=R[i];j!=i;j=R[j])
{
U[D[j]]=U[j];
D[U[j]]=D[j];
--S[col[j]];
}
}
}
void restore(int c)
{
for(int i=U[c];i!=c;i=U[i])
for(int j=L[i];j!=i;j=L[j])
++S[col[U[D[j]]=D[U[j]]=j]];
L[R[c]]=R[L[c]]=c;
}
bool Dance(int d)
{
if(R[0]==0)
{
ansd=d;
return true;
}
int c=R[0];
for(int i=R[0];i;i=R[i])
if(S[i]<S[c])c=i;
remove(c);
for(int i=D[c];i!=c;i=D[i])
{
ans[d]=row[i];
for(int j=R[i];j!=i;j=R[j])remove(col[j]);
if(Dance(d+1))return true;
for(int j=L[i];j!=i;j=L[j])restore(col[j]);
}
restore(c);
return false;
}
}dlx;
int main()
{
int cnt,x;
while(scanf("%d%d",&N,&M)!=EOF)
{
dlx.init(N,M);
for(int i=1;i<=N;i++)
{
scanf("%d",&cnt);
for(int j=1;j<=cnt;j++)
{
scanf("%d",&x);
dlx.Link(i,x);
}
}
if(!dlx.Dance(0))printf("NO");
else
{
printf("%d",dlx.ansd);
for(int i=0;i<dlx.ansd;i++)printf(" %d",dlx.ans[i]);
}
printf("\n");
}
return 0;
}