后缀自动机(不同子串的个数)hdu4416

F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist
 
      C/C++/Java Exams     
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests 
    DIY | Web-DIY beta
Recent Contests
Author ID 
Password 
  Register new ID

Good Article Good sentence

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2503    Accepted Submission(s): 710


Problem Description
In middle school, teachers used to encourage us to pick up pretty sentences so that we could apply those sentences in our own articles. One of my classmates ZengXiao Xian, wanted to get sentences which are different from that of others, because he thought the distinct pretty sentences might benefit him a lot to get a high score in his article.
Assume that all of the sentences came from some articles. ZengXiao Xian intended to pick from Article A. The number of his classmates is n. The i-th classmate picked from Article Bi. Now ZengXiao Xian wants to know how many different sentences she could pick from Article A which don't belong to either of her classmates?Article. To simplify the problem, ZengXiao Xian wants to know how many different strings, which is the substring of string A, but is not substring of either of string Bi. Of course, you will help him, won't you?
 

Input
The first line contains an integer T, the number of test data.  
For each test data
The first line contains an integer meaning the number of classmates.
The second line is the string A;The next n lines,the ith line input string Bi.
The length of the string A does not exceed 100,000 characters , The sum of total length of all strings Bi does not exceed 100,000, and assume all string consist only lowercase characters 'a' to 'z'.
 

Output
For each case, print the case number and the number of substrings that ZengXiao Xian can find.
 

Sample Input
      
      
3 2 abab ab ba 1 aaa bbb 2 aaaa aa aaa
 

Sample Output
      
      
Case 1: 3 Case 2: 3 Case 3: 1
对A串建立后缀自动机,然后用其他的串去匹配,每个节点维护一个cnt,表示最大匹配长度,最后统计一下,不同的子串数量就可以了

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=100010;
const int SIGMA_SIZE=26;
struct SAM_Node
{
    SAM_Node *par,*next[SIGMA_SIZE];
    int len,id,pos;
    int cnt;
    SAM_Node() {}
    SAM_Node(int _len)
    {
        par=0;
        len=_len;
        cnt=0;
        memset(next,0,sizeof(next));
    }
};
SAM_Node node[maxn*2],*root,*last;
int SAM_size;
SAM_Node *newSAM_Node(int len)
{
    node[SAM_size]=SAM_Node(len);
    node[SAM_size].id=SAM_size;
    return &node[SAM_size++];
}
SAM_Node *newSAM_Node(SAM_Node *p)
{
    node[SAM_size]=*p;
    node[SAM_size].id=SAM_size;
    return &node[SAM_size++];
}
void SAM_add(int x,int len)
{
    SAM_Node *p=last,*np=newSAM_Node(p->len+1);
    np->pos=len;
    last=np;
    while(p&&!p->next[x])
    {
        p->next[x]=np;
        p=p->par;
    }
    if(!p)np->par=root;
    else
    {
        SAM_Node *q=p->next[x];
        if(q->len==p->len+1)
            np->par=q;
        else
        {
            SAM_Node *nq=newSAM_Node(q);
            nq->len=p->len+1;
            q->par=nq;
            np->par=nq;
            while(p&&p->next[x]==q)
            {
                p->next[x]=nq;
                p=p->par;
            }
        }
    }
}
void SAM_init()
{
    SAM_size=0;
    root=last=newSAM_Node(0);
    node[0].pos=0;
}
void SAM_build(char *s)
{
    SAM_init();
    int len=strlen(s);
    for(int i=0;i<len;i++)
        SAM_add(s[i]-'a',i+1);
}
char s[maxn];
int N;
int cnt[maxn*2];
SAM_Node *sa[maxn*2];
int main()
{
    int T,cas=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&N);
        scanf("%s",s);
        SAM_build(s);
        int len=strlen(s);
        for(int i=0;i<=len;i++)cnt[i]=0;
        for(int i=0;i<SAM_size;i++)cnt[node[i].len]++;
        for(int i=1;i<=len;i++)cnt[i]+=cnt[i-1];
        for(int i=SAM_size-1;i>=0;i--)sa[--cnt[node[i].len]]=&node[i];

        LL ans=0;
        while(N--)
        {
            scanf("%s",s);
            SAM_Node *p=root;
            int num=0;
            len=strlen(s);
            for(int i=0;i<len;i++)
            {
                int c=s[i]-'a';
                if(p->next[c])num++,p=p->next[c];
                else
                {
                    while(p&&!p->next[c])p=p->par;
                    if(p){num=p->len+1;p=p->next[c];}
                    else{num=0,p=root;}
                }
                p->cnt=max(p->cnt,num);
            }
        }
        for(int i=SAM_size-1;i>=0;i--)
        {
            SAM_Node *p=sa[i];
            if(p->cnt>0)
            {
                if(p->par)p->par->cnt=max(p->par->cnt,p->cnt);
                if(p->cnt<p->len)ans+=p->len-p->cnt;
            }
            else ans+=p->len-(p->par?p->par->len:0);
        }
        printf("Case %d: %I64d\n",cas++,ans);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值