带权并查集(hdu2818)

Building Block

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3552    Accepted Submission(s): 1067


Problem Description
John are playing with blocks. There are N blocks (1 <= N <= 30000) numbered 1...N。Initially, there are N piles, and each pile contains one block. Then John do some operations P times (1 <= P <= 1000000). There are two kinds of operation:

M X Y : Put the whole pile containing block X up to the pile containing Y. If X and Y are in the same pile, just ignore this command.
C X : Count the number of blocks under block X

You are request to find out the output for each C operation.
 

Input
The first line contains integer P. Then P lines follow, each of which contain an operation describe above.
 

Output
Output the count for each C operations in one line.
 

Sample Input
  
  
6 M 1 6 C 1 M 2 4 M 2 6 C 3 C 4
 

Sample Output
  
  
1 0 2


维护一个cnt表示编号为i的block下面有多少个blocks,num表示当前集合中有多少个元素,然后在find里维护cnt

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=30010;
int N,P;
int top[maxn];
int pre[maxn],cnt[maxn];
int num[maxn];
void init()
{
    for(int i=0;i<maxn;i++)
        pre[i]=i,cnt[i]=0,num[i]=1;

}
int find(int x)
{
    if(x==pre[x])return x;
    int f=pre[x];

    pre[x]=find(pre[x]);
    cnt[x]+=cnt[f];
    return pre[x];

}
void unite(int x,int y)
{
    int a=find(x),b=find(y);
    if(a==b)return;
    cnt[a]=num[b];
    pre[a]=b;
    num[b]+=num[a];
    num[a]=0;
}
int main()
{
    while(scanf("%d",&P)!=EOF)
    {
        init();
        char op[5];
        int x,y;
        while(P--)
        {
            scanf("%s%d",op,&x);
            if(op[0]=='M')
            {
                scanf("%d",&y);
                unite(x,y);
            }
            else
            {
                find(x);
                printf("%d\n",cnt[x]);
            }
        }
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值