状态压缩dp(hdu3406)

Baseball of Planet Pandora

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 310    Accepted Submission(s): 119


Problem Description
The baseball game of planet Pandora is similar to the game of the Earth. In the game field, there are four bases which are named “home base”, “first base”, “second base” and “third base”. At the beginning, nobody is on the bases. There are two teams, one is the attacking team, and the other is the defending team.

One by one, all players of the attacking team goes to the home base and bats the ball thrown by the defending team.  

There are four possible results of a bat:  
1. “Out”. In this case, the batter misses the ball, so he is disqualified and leaves the game.  

2.“Bingle”. In this case, the batter hits the ball, but the ball doesn’t fly out of the field. Then the batter can advance to the first base, and other players of the attacking team who are already on a base can advance to next base (The next base of the third base is the home base). If a player returns to the home base, he scores one point for his team.

3.“Allrun”. In this case, the batter hits the ball out of the field and then all the players on the bases (including the batter) can run to the home base and each scores one point for his team. So in this case, the attacking team can score at least 1 point, and at most 4 points.  

4.“Sacrifice”. In this case, the batter chooses not to bat and leaves the field. According to the rule, in this case, the players still on the bases can advance to next base. So the player advancing to the home base this way scores one point. But if there have already been two batters who get an “Out” or a “Sacrifice” before, “Sacrifice” will end the game immediately and the attacking team can’t score any point in this “Sacrifice”.

  According to the rule, a player must leave the field immediately after he scores one point for his team. The game ends after every player of the attacking team has batted once(A “Sacrifice” is also regarded as a bat), or after there has been 3 batters who get an “Out” or an “Sacrifice”.  

Avatar is the coach of an attacking team. He knows that the same player performs differently when the player takes different turns. For example, if you let Jack to be the first batter, he will definitely get an “Out”, but if you let him play in the third turn, he will get an “Allrun”. Avatar knows his men very well. He asked you to find out the best “batting order” for his team. If the team bats in that order, their score will be maximized.
 

Input
There are multiple test cases, ended by 0.

For each test case:
The first line contains an integer n(1<=n <=15), meaning the number of players in Avatar’s team. All players are numbered for 1 to n.

Then a n×n matrix A follows. Aij describes what result the player i will get if he is the jth batter.( i and j start from 1 )

Following is the meaning of the value of Aij:
0 means the result is “Out”
1 means the result is “Sacrifice”
2 means the result is “Bingle”
3 means the result is “Allrun”
 

Output
For each test case, print one line containing the highest score Avatar’s team can get in the game.
 

Sample Input
  
  
5 0 2 0 1 2 1 0 2 0 2 0 2 1 2 0 0 2 2 1 2 2 1 0 2 0 0
 

Sample Output
  
  
2
 

Source
 


dp[i][j][k]表示出厂状态为i,三个垒的状态为j,出厂人数为k的最高得分


#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
int a[20][20],n,ans,dp[(1<<15)+2][10][4],bit[(1<<16)],st;
void init()
{
    int cnt;
    for(int i=0;i<(1<<16);i++)
    {
        cnt=0;
        for(int j=0;j<17;j++)
            if(i&(1<<j))
                cnt++;
        bit[i]=cnt;
    }
}

int main()
{
//    freopen("in.txt","r",stdin);
    init();
    while(scanf("%d",&n)&&n)
    {
        ans=0;
        for(int i=0;i<n;i++)
            for(int j=1;j<=n;j++)
                scanf("%d",&a[i][j]);
        memset(dp,-1,sizeof(dp));
        dp[0][0][0]=0;
        for(int i=0;i<(1<<n);i++)
        {
            for(int j=0;j<(1<<3);j++)
            {
                for(int k=0;k<3;k++)
                {
                    if(dp[i][j][k]==-1) continue;
                    ans=max(ans,dp[i][j][k]);
                    if(k==3) continue;
                    for(int l=0;l<n;l++)
                        if( !(i&(1<<l)) )
                        {
                            st=(i|(1<<l));
                            int cnt=bit[st];
                            if (a[l][cnt]==0)
                            {
                                dp[st][j][k+1]=max(dp[st][j][k+1],dp[i][j][k]);
                            }
                            if(a[l][cnt]==1)
                            {
                                if(k==2) continue;
                                if((j&4)!=0) dp[st][(j<<1) & 7][k+1]=max(dp[st][(j<<1) & 7][k+1],dp[i][j][k]+1);
                                else dp[st][(j<<1) & 7][k+1]=max(dp[st][(j<<1) & 7][k+1],dp[i][j][k]);
                            }
                            if(a[l][cnt]==2)
                            {
                                if((j&4)!=0) dp[st][((j<<1) & 7)+1][k]=max(dp[st][((j<<1) & 7)+1][k],dp[i][j][k]+1);
                                else dp[st][((j<<1) & 7)+1][k]=max(dp[st][((j<<1) & 7)+1][k],dp[i][j][k]);
                            }
                            if(a[l][cnt]==3)
                            {
                                dp[st][0][k]=max(dp[st][0][k],dp[i][j][k]+((j & 1)!=0)+((j & 2)!=0)+((j & 4)!=0)+1);
                            }
                        }
                }
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值