Article
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 313 Accepted Submission(s): 95
Problem Description
As the term is going to end, DRD begins to write his final article.
DRD uses the famous Macrohard's software, World, to write his article. Unfortunately this software is rather unstable, and it always crashes. DRD needs to write n characters in his article. He can press a key to input a character at time i+0.1 , where i is an integer equal or greater than 0. But at every time i−0.1 for integer i strictly greater than 0, World might crash with probability p and DRD loses his work, so he maybe has to restart from his latest saved article. To prevent write it again and again, DRD can press Ctrl-S to save his document at time i . Due to the strange keyboard DRD uses, to press Ctrl-S he needs to press x characters. If DRD has input his total article, he has to press Ctrl-S to save the document.
Since World crashes too often, now he is asking his friend ATM for the optimal strategy to input his article. A strategy is measured by its expectation keys DRD needs to press.
Note that DRD can press a key at fast enough speed.
DRD uses the famous Macrohard's software, World, to write his article. Unfortunately this software is rather unstable, and it always crashes. DRD needs to write n characters in his article. He can press a key to input a character at time i+0.1 , where i is an integer equal or greater than 0. But at every time i−0.1 for integer i strictly greater than 0, World might crash with probability p and DRD loses his work, so he maybe has to restart from his latest saved article. To prevent write it again and again, DRD can press Ctrl-S to save his document at time i . Due to the strange keyboard DRD uses, to press Ctrl-S he needs to press x characters. If DRD has input his total article, he has to press Ctrl-S to save the document.
Since World crashes too often, now he is asking his friend ATM for the optimal strategy to input his article. A strategy is measured by its expectation keys DRD needs to press.
Note that DRD can press a key at fast enough speed.
Input
First line: an positive integer
0≤T≤20
indicating the number of cases.
Next T lines: each line has a positive integer n≤105 , a positive real 0.1≤p≤0.9 , and a positive integer x≤100 .
Next T lines: each line has a positive integer n≤105 , a positive real 0.1≤p≤0.9 , and a positive integer x≤100 .
Output
For each test case: output ''Case #k: ans'' (without quotes), where
k
is the number of the test cases, and
ans
is the expectation of keys of the optimal strategy.
Your answer is considered correct if and only if the absolute error or the relative error is smaller than 10−6 .
Your answer is considered correct if and only if the absolute error or the relative error is smaller than 10−6 .
Sample Input
2 1 0.5 2 2 0.4 2
Sample Output
Case #1: 4.000000 Case #2: 6.444444
Source
参考自:http://www.cnblogs.com/qscqesze/p/4543740.html
比赛的时候没做出来,赛后看了一下,还是挺简单的
首先dp[i]表示敲i个字符不崩溃的概率
dp[i]=(dp[i-1]+1)*(1-p)+(dp[i-1]+1+dp[i])*p
第一部分表示第i个字符没有崩溃,第二部分表示第i个字符崩溃,那还要敲i个字符
然后贪心枚举分成多少段
#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=100010;
const double INF=1e16;
double dp[maxn];
int N,X;
double P;
int main()
{
int T,cas=1;
scanf("%d",&T);
while(T--)
{
scanf("%d%lf%d",&N,&P,&X);
memset(dp,0,sizeof(dp));
for(int i=1;i<=N;i++)
dp[i]=(dp[i-1]+1)/(1-P);
double ans=INF;
for(int i=1;i<=N;i++)
{
int a=N/i,b=N%i;
ans=min(ans,dp[a+1]*b+dp[a]*(i-b)+X*i);
}
printf("Case #%d: %.6lf\n",cas++,ans);
}
return 0;
}