hdu3709 - Balanced Number(2010 Asia Chengdu Regional Contest)数位dp

Balanced Number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2720    Accepted Submission(s): 1242


Problem Description
A balanced number is a non-negative integer that can be balanced if a pivot is placed at some digit. More specifically, imagine each digit as a box with weight indicated by the digit. When a pivot is placed at some digit of the number, the distance from a digit to the pivot is the offset between it and the pivot. Then the torques of left part and right part can be calculated. It is balanced if they are the same. A balanced number must be balanced with the pivot at some of its digits. For example, 4139 is a balanced number with pivot fixed at 3. The torqueses are 4*2 + 1*1 = 9 and 9*1 = 9, for left part and right part, respectively. It's your job
to calculate the number of balanced numbers in a given range [x, y].
 

Input
The input contains multiple test cases. The first line is the total number of cases T (0 < T ≤ 30). For each case, there are two integers separated by a space in a line, x and y. (0 ≤ x ≤ y ≤ 10 18).
 

Output
For each case, print the number of balanced numbers in the range [x, y] in a line.
 

Sample Input
  
  
2 0 9 7604 24324
 

Sample Output
  
  
10 897
 

Author
GAO, Yuan
 

Source


题意:求出[x,y]之间的平衡数,所谓的平衡数,就是以其中一个数为中点,两边以杠杆原理一样的平衡

思路:数位dp,dp[cur[mid][l]表示到当前位置,以mid为中点,和为l的有多少


#include<bits/stdc++.h>
using namespace std;
typedef long long LL;

const int maxn=20;
int dig[maxn];
LL dp[maxn][maxn][2010];
LL x,y;
LL dfs(int cur,int mid,int l,int e)
{
    if(cur<0)return l==0;
    if(l<0)return 0;
    if(!e&&dp[cur][mid][l]!=-1)
        return dp[cur][mid][l];
    LL ans=0;
    int end=e?dig[cur]:9;
    for(int i=0;i<=end;i++)
    {
        int tmp=l;
        tmp+=(cur-mid)*i;
        ans+=dfs(cur-1,mid,tmp,e&&i==end);
    }
    if(!e)dp[cur][mid][l]=ans;
    return ans;
}
LL solve(LL n)
{
    memset(dp,-1,sizeof(dp));
    int len=0;
    while(n)
    {
        dig[len++]=n%10;
        n/=10;
    }
    LL ans=0;
    for(int i=0;i<len;i++)
        ans+=dfs(len-1,i,0,1);
    return ans-len+1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%I64d%I64d",&x,&y);
        printf("%I64d\n",solve(y)-solve(x-1));
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值