ZOJ 3543 - Number String(dp)

Number String

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter ‘I’ (increasing) if the second element is greater than the first one, otherwise write down the letter ‘D’ (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is “DIIDID”.

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters ‘I’, ‘D’ or ‘?’, representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The ‘?’ in these strings can be either ‘I’ or ‘D’.

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

Sample Input

II
ID
DI
DD
?D
??

Sample Output

1
2
2
1
3
6

Hint

Permutation {1,2,3} has signature “II”.
Permutations {1,3,2} and {2,3,1} have signature “ID”.
Permutations {3,1,2} and {2,1,3} have signature “DI”.
Permutation {3,2,1} has signature “DD”.
“?D” can be either “ID” or “DD”.
“??” gives all possible permutations of length 3.
状态f[i][j]表示长度为I的全排列,符合字符串的要求,最后一位数字是j的方案数。

重点在要始终保持是f算的排列的数量,然后转移时用这些推出来新的情况。

就是j<=i

从长度是i-1的排列推长度是i的时候。因为确定了最后一位以后,前面不考虑数值,考虑名次还是一个i-1的排列的某一个。所以,如果要再最后加一个j,可以考虑认为是把前面大于等于j的数字都加一,就得到i的一个排列。
对于’I’或者’?’
  dp[i][j]+=dp[i][2..j-1]
对于’D’或者’?’
  dp[i][j]+=dp[i][j..i-1]

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=1010;
const int maxm=1010;
const int INF=0x3f3f3f3f;
const LL MOD= 1000000007;

LL dp[maxn][maxn],sum[maxn][maxn];
char str[maxn];

int main()
{
    while(scanf("%s",str+1)!=EOF)
    {
        int len=strlen(str+1);
        memset(dp,0,sizeof(dp));
        memset(sum,0,sizeof(sum));
        dp[1][1]=1;
        sum[1][1]=1;
        for(int i=1; i<=len; i++)
            for(int j=1; j<=i+1; j++)
            {
                if(str[i]=='I') dp[i+1][j]=sum[i][j-1];
                else if(str[i]=='D') dp[i+1][j]=(sum[i][i]-sum[i][j-1]+MOD)%MOD;
                else dp[i+1][j]=sum[i][i];
                sum[i+1][j]=(sum[i+1][j-1]+dp[i+1][j])%MOD;
            }
        printf("%lld\n",sum[len+1][len+1]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值