PAT-A | 1003 | Emergency

10 篇文章 0 订阅
2 篇文章 0 订阅

1003. Emergency (25)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4

以下是我自己的不全对的解法,就是把Dijkstra稍微改动一下,但是测试用例只通过了前两个,后面4个都没有通过。看了浙大的《数据结构学习与实验指导》6-8 城市间紧急救援的解答才明白问题出在最短路径条数的统计上(我自己设计了一个测试用例,也发现了这个问题,但是不知道怎么解决)。

#include <iostream>

#define INF 65535
using namespace std;

const int MAXSIZE = 500;
struct MGraph {
	//int Edge[MAXSIZE][MAXSIZE];
	int **Edge;
	int *teams;
	int N;
	int M;//number of edges
	//if no edge between a and b, Edge[a][b] = INF
};

void CreateGraph(MGraph &G, int &source, int &dest)
{
	int a, b, w;

	cin >> G.N >> G.M;
	cin >> source >> dest;

	G.Edge = new int*[G.N];
	G.teams = new int[G.N];
	//initialize the number of teams of each city
	for (int i = 0; i != G.N; ++i) {
		G.Edge[i] = new int[G.N];
		cin >> G.teams[i];
		for (int j = 0; j != G.N; ++j) {
			G.Edge[i][j] = INF;
		}
	}
	//initialize edge and weight
	for (int i = 0; i != G.M; ++i) {
		cin >> a >> b >> w;
		G.Edge[a][b] = w;
		G.Edge[b][a] = w;
	}
}
//Dijkstra Alg
//path[], dist[], set[]
//return the number of same shortest pathes
int Dijkstra(MGraph G, int s, int path[], int dist[], int sum[])
{
	int *set = new int[G.N];
	int cnt = 1;

	//initialize
	for (int i = 0; i != G.N; ++i) {
		set[i] = 0;
		dist[i] = G.Edge[s][i];
		if (G.Edge[s][i] != INF) {
			path[i] = s;
			sum[i] = G.teams[s] + G.teams[i];
		} else {
			path[i] = -1;
			sum[i] = G.teams[i];
		}
	}
	set[s] = 1;
	path[s] = -1;

	for (int i = 0; i != G.N; ++i) {
		//find min and add to set[]
		int min = INF, v = 0;
		for (int j = 0; j != G.N; ++j) {
			if (set[j] == 0 && dist[j] < min) {
				min = dist[j];
				v = j;
			}
		}
		set[v] = 1;

		//refresh dist[]
		for (int j = 0; j != G.N; ++j) {
			if (G.Edge[v][j] != INF && set[j] == 0) {
				if (dist[v] + G.Edge[v][j] < dist[j]) {
					dist[j] = dist[v] + G.Edge[v][j];
					sum[j] = sum[v] + G.teams[j];
					path[j] = v;
				} else if (dist[v] + G.Edge[v][j] == dist[j]) {
					++cnt;
					if (sum[v] + G.teams[j] > sum[j]) {
						sum[j] = sum[v] + G.teams[j];
					}
					path[j] = v;
				}
			}
		}
	}

	delete[]set;
	return cnt;
}

void PrintPath(int path[], int a)
{
	int stack[MAXSIZE], top = -1;
	while (path[a] != -1) {
		stack[++top] = a;
		a = path[a];
	}
	stack[++top] = a;

	while (top != -1) {
		cout << stack[top--] << " ";
	}
}

int main()
{
	MGraph G;
	int *path, *dist, *sum;
	int source, dest, cnt;

	CreateGraph(G, source, dest);
	path = new int[G.N];
	dist = new int[G.N];
	sum = new int[G.N];
	cnt = Dijkstra(G, source, path, dist, sum);
	cout << cnt << " " << sum[dest] << endl;
	//PrintPath(path, dest);

	//remember to free G's memory
	delete[]path;
	delete[]dist;
}

解题要点:

这道题的关键是如何统计最短路径的条数:

需要记录从S到每个结点的最短路的条数,这些记录初始化为0,S的记录初始化为1。每当发现一个结点的新的更短路径时,其“最短路径条数”等同于该路径上前驱结点的“最短路径条数”(注意:这里不是更新为1);而发现等长最短路径时,其“最短路径条数”应该加上该路径上前驱结点的“最短路径条数”(注意:这里不是当前路径条数加1)

实现要点:

输入有可能是完全图,所以用邻接矩阵表示比较方便。

需要存储边的距离edge[][]和救援队数量teams[],在结构体中增加sum[],记录经过i结点可以集结的救援队数量;用数组count[]记录每个结点最短路径的条数;用数组pre[]记录路径中每个结点的前驱结点。当最短路径需要更新的时候,不仅要更新最短路径长度dist[],还需要更新sum[],count[]和pre[]

#include <iostream>

#define INF 65535
using namespace std;

struct MGraph {
	int **Edge;//if no edge between a and b, Edge[a][b] = INF
	int *teams;// teams[] record the number of rescue teams in the i-th city
	int *dist;// dist[] record the shortest distance from source to i-th vertex(city)
	int *sum;// sum[] record the biggest sum of rescue teams from source to i-th city
	int *count;// record the number of shortest pathes from source to i-th vertex
	int *pre;// record the previous vertex of i-th vertex in the shortest path, its function like path[]
	int N;//  
	int M;//number of edges
};

void CreateGraph(MGraph &G, int &source, int &dest)
{
	int a, b, w;

	cin >> G.N >> G.M;
	cin >> source >> dest;

	G.Edge = new int*[G.N];
	G.teams = new int[G.N];
	G.dist = new int[G.N];
	G.sum = new int[G.N];
	G.count = new int[G.N];
	G.pre = new int[G.N];
	//initialize the number of teams of each city
	for (int i = 0; i != G.N; ++i) {
		G.Edge[i] = new int[G.N];

		cin >> G.teams[i];

		for (int j = 0; j != G.N; ++j) {
			G.Edge[i][j] = INF;
		}
	}
	//initialize edge and weight
	for (int i = 0; i != G.M; ++i) {
		cin >> a >> b >> w;
		G.Edge[a][b] = w;
		G.Edge[b][a] = w;
	}
}
//Dijkstra Alg
void Dijkstra(MGraph G, int s)
{
	int *set = new int[G.N];

	//initialize
	G.count[s] = 1;
	for (int i = 0; i != G.N; ++i) {
		set[i] = 0;
		G.dist[i] = G.Edge[s][i];
		if (G.Edge[s][i] != INF) {
			G.pre[i] = s;
			G.count[i] = G.count[s];
			G.sum[i] = G.teams[s] + G.teams[i];
		} else {
			G.pre[i] = -1;
			//ps this statement: if i == 0, G.count[0] = 0, then G.count[s] = 1 is invalid
			if (i != 0) G.count[i] = 0;
			G.sum[i] = G.teams[i];
		}
	}
	set[s] = 1;
	G.count[s] = 1;
	G.pre[s] = -1;

	//key operation
	for (int i = 0; i != G.N; ++i) {
		//find min and add to set[]
		int min = INF, v = 0;
		for (int j = 0; j != G.N; ++j) {
			if (set[j] == 0 && G.dist[j] < min) {
				min = G.dist[j];
				v = j;
			}
		}
		set[v] = 1;

		//refresh dist[]
		for (int j = 0; j != G.N; ++j) {
			if (G.Edge[v][j] != INF && set[j] == 0) {
				if (G.dist[v] + G.Edge[v][j] < G.dist[j]) {
					G.dist[j] = G.dist[v] + G.Edge[v][j];
					G.sum[j] = G.sum[v] + G.teams[j];

					G.pre[j] = v;
					G.count[j] = G.count[G.pre[j]];					
				} else if (G.dist[v] + G.Edge[v][j] == G.dist[j]) {
					if (G.sum[v] + G.teams[j] > G.sum[j]) {
						G.sum[j] = G.sum[v] + G.teams[j];
					}

					G.pre[j] = v;
					G.count[j] += G.count[G.pre[j]];
				}
			}
		}
	}

	delete[]set;
}

int main()
{
	MGraph G;
	
	int source, dest;

	CreateGraph(G, source, dest);
	
	Dijkstra(G, source);
	cout << G.count[dest] << " " << G.sum[dest] << endl;

	//remember to free G's memory
	for (int i = 0; i != G.N; ++i) {
		delete[]G.Edge[i];
	}
	delete[]G.Edge;
	delete[]G.dist;
	delete[]G.teams;
	delete[]G.count;
	delete[]G.pre;
	delete[]G.sum;
}


//test file
//6 7 0 5
//1 2 1 1 2 1
//0 1 1
//0 2 2
//1 2 1
//2 3 1
//2 4 1
//3 5 1
//4 5 1





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值