SGU 102

6 篇文章 0 订阅

102. Coprimes

time limit per test: 0.25 sec.
memory limit per test: 4096 KB


For given integer N (1<=N<=104) find amount of positive numbers not greater than N that coprime with N. Let us call two positive integers (say, A and B, for example) coprime if (and only if) their greatest common divisor is 1. (i.e. A and B are coprime iff gcd(A,B) = 1).


Input

Input file contains integer N.


Output

Write answer in output file.


Sample Input

9


Sample Output

6


水题

#include<stdio.h>

const bool isOJ = 0;

int GCD(int a,int b){
	if (b == 0) return a;
	else return GCD(b,a%b);
}

int Work(){
	int n;
	if (scanf("%d",&n) == EOF)
		return 0;
	int sum = 0,i;
	for (i = 1;i <= n;i++)
		sum += GCD(n,i) == 1;
	printf("%d\n",sum);
	return 1;
}

int main(){
	if (!isOJ)
		freopen("/Users/mac/Desktop/test.in","r",stdin);
	while(Work());
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值