poj_1082_Calendar Game(博弈论)

本文介绍了一个博弈论问题——Calendar Game,玩家在指定日期范围内按规则交替报日期,最后报到2001年11月4日的人获胜。通过博弈论的必胜和必败状态分析,发现日期的月加日为偶数时先手必胜,为奇数时先手必败。特殊日期如9月30日和11月30日为必胜状态,不遵循常规规律。
摘要由CSDN通过智能技术生成

Calendar Game
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4546 Accepted: 2136

Description

Adam and Eve enter this year's ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid. 

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game. 

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy. 

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.

Input

The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.

Output

Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO".

Sample Input

3 
2001 11 3 
2001 11 2 
2001 10 3 

Sample Output

YES
NO
NO

Source


题型:博弈论(找规律)


题意:

两个人玩一种游戏,游戏内容为:在1900年1月1日到2001年11月4日之间的某一个日期开始,分别往下报日期,有两种报法,可以报该天的下一天,也可以报下个月的这一天(如果下个月没有这一天则不可以这样报),最后报到2001年11月4日的人赢。问对于给定的日期,先手是赢是输。


分析:

       首先了解一个博弈论相关的定理:如果一个状态的后继状态都是必胜状态,那么它是必败状态。如果一个状态的后继状态中存在必败状态,那么它是必胜状态。

       第一个必败状态是2001.11.04。由此可以推出其他任何时间的状态。

       从后往前推,对于某一天的胜败由两天决定:该天后一天和后一个月的同一天(有时没有第二个因素)
       若两者都是必胜态,则这一天必败。若有一天为必败,则这一天必胜。
       2001年11月4日到2001年10月4日胜败是交替的,可以发现“月+日”为偶数时必胜,为奇数是必败。
       2001年10月4日必胜,10月3日由10月4日和11月3号决定,两者都是必胜,所以10月3号必败。同理可判定10月剩余的日子。相邻的两个月的同一天胜败情况相反,但这一天“月+日”的奇偶性也相反(月份或日期两者只有一个减一),所以结论成立。
       但是需要考虑几种特殊情况:
       9月只有30天,9月30号由10月1号(必败)和10月30号(必胜)决定,为必胜。与上述结论矛盾,但9月29号为必胜,9月后面的日子依然遵循这样的规律,可见9月30号为一个特殊情况,同样的特殊情况还有11月30号(用同样的方法判断4,6月30号发现遵循结论),对于2月(不管是闰年还是平年)发现也符合。
总结:月与号和为偶数的天状态为必胜,为奇数的天状态为必败。特殊情况为09.30和11.30,这两天的状态是必胜。


代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int main(){
    int t,y,m,d;
    scanf("%d",&t);
    while(t--){
        //09.30和11.30
        scanf("%d%d%d",&y,&m,&d);
        if((m==9&&d==30)||(m==1&&d==30)){
            printf("YES\n");
            continue;
        }
        if((m+d)%2==0) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值