Prime Land
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 2508 | Accepted: 1171 |
Description
Everybody in the Prime Land is using a prime base number system. In this system, each positive integer x is represented as follows: Let {pi}i=0,1,2,... denote the increasing sequence of all prime numbers. We know that x > 1 can be represented in only one way in the form of product of powers of prime factors. This implies that there is an integer kx and uniquely determined integers e
kx, e
kx-1, ..., e
1, e
0, (e
kx > 0), that
The sequence
(e kx, e kx-1, ... ,e 1, e 0)
is considered to be the representation of x in prime base number system.
It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple.
Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''.
Help people in the Prime Land and write a corresponding program.
For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi.
(e kx, e kx-1, ... ,e 1, e 0)
is considered to be the representation of x in prime base number system.
It is really true that all numerical calculations in prime base number system can seem to us a little bit unusual, or even hard. In fact, the children in Prime Land learn to add to subtract numbers several years. On the other hand, multiplication and division is very simple.
Recently, somebody has returned from a holiday in the Computer Land where small smart things called computers have been used. It has turned out that they could be used to make addition and subtraction in prime base number system much easier. It has been decided to make an experiment and let a computer to do the operation ``minus one''.
Help people in the Prime Land and write a corresponding program.
For practical reasons we will write here the prime base representation as a sequence of such pi and ei from the prime base representation above for which ei > 0. We will keep decreasing order with regard to pi.
Input
The input consists of lines (at least one) each of which except the last contains prime base representation of just one positive integer greater than 2 and less or equal 32767. All numbers in the line are separated by one space. The last line contains number 0.
Output
The output contains one line for each but the last line of the input. If x is a positive integer contained in a line of the input, the line in the output will contain x - 1 in prime base representation. All numbers in the line are separated by one space. There is no line in the output corresponding to the last ``null'' line of the input.
Sample Input
17 1 5 1 2 1 509 1 59 1 0
Sample Output
2 4 3 2 13 1 11 1 7 1 5 1 3 1 2 1
Source
题型:数论
题意:
一个数可以被分解为许多个素数。现在给出一些数及其次方,其可以相乘得到x,将x-1分解,输出其素数与其相应的幂数。
分析:
本质上是水题,但是对输入的处理有些麻烦,只能按字符串的形式用gets()输入,然后在将其处理成数字。
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1000;
int facs[maxn];
char str[123456];
int cnt;
void find_fac(int n){
cnt=0;
for(int i=2;i*i<=n;i+=2){
while(!(n%i))
n/=i,facs[cnt++]=i;
if(i==2) --i;
}
if(n>1) facs[cnt++]=n;
}
int cmp(int a,int b){
return a>b;
}
int main(){
char a[100];
while(1){
gets(str);
if(str[0]=='0') break;
int s=0,e=0;
int n=1;
int x,y;
int len=strlen(str);
int flag=1;
for(int i=0;i<=len;i++){
if(str[i]!=' '&&str[i]!='\0'){
e++;
}
else{
int oo=0;
for(int j=s;j<=e;j++){
a[oo]=str[j];
oo++;
}
a[oo]='\0';
//printf("%s\n",a);
s=i+1;
e=i+1;
if(flag==1){
sscanf(a,"%d",&x);
//cout<<"x="<<x<<endl;
}
else{
sscanf(a,"%d",&y);
for(int j=1;j<=y;j++)
n*=x;
//cout<<"y="<<y<<endl;
//cout<<n<<endl;
}
flag=3-flag;
}
}
n--;
//cout<<n<<endl;
int hh=1;
find_fac(n);
//for(int i=0;i<cnt;i++){
// cout<<facs[i]<<endl;
//}
sort(facs,facs+cnt,cmp);
facs[cnt]=-1;
printf("%d",facs[0]);
for(int i=1;i<=cnt;i++){
if(facs[i]==facs[i-1]){
hh++;
}
else{
printf(" %d",hh);
if(i<cnt){
printf(" %d",facs[i]);
}
hh=1;
}
}
printf("\n");
}
return 0;
}