NYOJ sum 215

Sum

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N. 

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem. 
输入
The input consists N test cases.
The only line of every test cases contains a positive integer S (0< S <= 100000) which represents the sum to be obtained.
A zero terminate the input.
The number of test cases is less than 100000.
输出
The output will contain the minimum number N for which the sum S can be obtained.
样例输入
3
12
0
样例输出
2
7

 

#include<stdio.h>
#include<stdlib.h>
int main()
{
	int n,i;
	while(scanf("%d",&n) && n!= 0)
	{
		int sum=0;
		for(i=1; ; i++)
		{
			sum += i;
			if(n == sum) 
			{
					printf("%d\n",i);
					break;
			}
		
			if(sum > n)
			{
				if((sum - n)%2 == 0)
				{
					printf("%d\n",i);
					break;
				}
			}
				
			
		}
	}
	return 0;
}
	


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值