NUC1196 Sum【水题+数学题】

Sum

时间限制: 1000ms 内存限制: 65536KB
通过次数: 1总提交次数: 1
问题描述

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.

输入描述
The only line contains in the first line a positive integer S (0 < S ≤ 100000) which represents the sum to be obtained.
输出描述
The output will contain the minimum number N for which the sum S can be obtained.
样例输入
12
样例输出
7
来源
PKU
提示
The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.


问题分析:(略)

这个问题和《POJ1844 Sum【水题+数学题】》是同一个问题,代码直接用就AC了。

程序说明:参见参考链接。

参考链接:POJ1844 Sum【水题+数学题】

题记:程序做多了,不定哪天遇见似曾相识的。

AC的C++程序如下:

/* POJ1844 Sum */

#include <iostream>
#include <math.h>

using namespace std;

int main()
{
    int s;

    while(cin >> s) {
        for(int i=sqrt(s); ;i++) {
            int sn = (i + 1) * i / 2;
            if(sn >= s && (sn - s) % 2 == 0) {
                cout << i << endl;
                break;
            }
        }
    }

    return 0;
}




转载于:https://www.cnblogs.com/tigerisland/p/7563666.html

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值