hdu 2112 HDU Today

Problem Description
经过锦囊相助,海东集团终于度过了危机,从此,HDU的发展就一直顺风顺水,到了2050年,集团已经相当规模了,据说进入了钱江肉丝经济开发区500强。这时候,XHD夫妇也退居了二线,并在风景秀美的诸暨市浬浦镇陶姚村买了个房子,开始安度晚年了。
这样住了一段时间,徐总对当地的交通还是不太了解。有时很郁闷,想去一个地方又不知道应该乘什么公交车,在什么地方转车,在什么地方下车(其实徐总自己有车,却一定要与民同乐,这就是徐总的性格)。
徐总经常会问蹩脚的英文问路:“Can you help me?”。看着他那迷茫而又无助的眼神,热心的你能帮帮他吗?
请帮助他用最短的时间到达目的地(假设每一路公交车都只在起点站和终点站停,而且随时都会开)。
 

Input
输入数据有多组,每组的第一行是公交车的总数N(0<=N<=10000);
第二行有徐总的所在地start,他的目的地end;
接着有n行,每行有站名s,站名e,以及从s到e的时间整数t(0<t<100)(每个地名是一个长度不超过30的字符串)。
note:一组数据中地名数不会超过150个。
如果N==-1,表示输入结束。
 

Output
如果徐总能到达目的地,输出最短的时间;否则,输出“-1”。
 

Sample Input
  
  
6 xiasha westlake xiasha station 60 xiasha ShoppingCenterofHangZhou 30 station westlake 20 ShoppingCenterofHangZhou supermarket 10 xiasha supermarket 50 supermarket westlake 10 -1
 

Sample Output
  
  
50 Hint: The best route is: xiasha->ShoppingCenterofHangZhou->supermarket->westlake 虽然偶尔会迷路,但是因为有了你的帮助 **和**从此还是过上了幸福的生活。 ――全剧终――
 

Author
lgx
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1874  1217  2680  1142  1385 
 


此题为典型的Dijkstra算法,但是不能单独使用D算法,其中包括将字符串转变为int类型的各种起点,此处可以直接用map来记录,但是用C++容易超时,希望大家注意

#include <iostream>
#include <cstring>
#include <cstdio>
#include <map>
using namespace std;

const int INF=0x3f3f3f;
int map1[1005][1005];
int dist[1005];
bool vis[1005];

void  dijkstra(int begin,int end)
{
    for(int i=1;i<=end;i++)
    {
        dist[i]=map1[begin][i];
        vis[i]=false;
    }
    dist[begin]=0;
    vis[begin]=true;
    for(int i=2;i<=end;i++)
    {
        int post=0,min=INF;
        for(int j=1;j<=end;j++)
        {
            if(!vis[j]&&dist[j]<min)
            {
                min=dist[j];
                post=j;
            }
        }
        vis[post]=true;
        for(int j=1;j<=end;j++)
        {
            if(!vis[j]&&dist[j]>dist[post]+map1[post][j])
            {
                dist[j]=dist[post]+map1[post][j];
            }
        }
    }
    //cout<<dist[2]<<endl;
}
int main()
{
    int n,flag,ans,it;
    char a[30],b[30];
    int time;
    char start[30],end[30];
    map<string,int>m;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==-1)
            return 0;
        m.clear();
        flag=0;
        for(int i=1; i<=1005; i++)
            for(int j=1; j<=1005; j++)
                map1[i][j]=INF;
        //memset(map1,INF,sizeof(map1));
        //cin>>start>>end;
        scanf("%s%s",start,end);
        if(strcmp(start,end)==0)
        {
            flag=1;
        }
        m[start]=1;
        m[end]=2;
        ans=3;
        for(int i=1;i<=n;i++)
        {
            //cin>>a>>b>>time;
            scanf("%s%s%d",a,b,&time);
            if(!m[a])
                m[a]=ans++;
            if(!m[b])
                m[b]=ans++;
            map1[m[a]][m[b]]=time;
            map1[m[b]][m[a]]=time;
        }
        //cout<<ans<<endl;
        if(flag)
            //cout<<"0"<<endl;
            printf("0\n");
        else
        {
            dijkstra(1,ans);
            if(dist[2]==INF)
                //cout<<"-1"<<endl;
                printf("-1\n");
            else
                //cout<<dist[2]<<endl;
                printf("%d\n",dist[2]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值