HDU 2601 An easy problem

 

Problem Description
When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve.
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

Input
The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10 10).

Output
For each case, output the number of ways in one line.

Sample Input
  
  
2 1 3

Sample Output
  
  
0 1
PS: 本题考察的是整数的因子的个数, i * j + i + j =n,即为(i+1)*(j+1)=n+1,转化为了求解n+1的因子的个数
问题就转化成了求有多少个大于2的整数的积为N+1。注意i要小于等于j,所以只要试到到N+1的开方就可以了。
 
#include<iostream>
#include<cmath>
using namespace std;

int main()
{
    int n;
    long long num;
    int res;
    cin>>n;
    while(n--)
    {
        res=0;
        cin>>num;
        num++;
        int len=sqrt(num*1.0);
        //cout<<len<<"hhhjj"<<endl;
        for(int i=2; i<=len; i++)
        {
            if(num%i==0)
            {
                res++;
            }
        }
        cout<<res<<endl;
    }
    return 0;
}

n=i*j+i+j;
 =(i+1)*j+i;
(n-i)=(i+1)*j;
所以只要(n-i)%(i+1)==0,则满足条件,和j没关系
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int t,j;
    __int64 n;
    int m,cnt;
    scanf("%d",&t);
    while(t--)
    {
        cnt=0;
        scanf("%I64d",&n);
        m=(-1+sqrt((double)(1+n)));
        //m=(int)(sqrt(n));
        for(int i=1; i<=m; i++)
        {
            if((n-i)%(i+1)==0)
            {
                //j=(n-i)/(i+1);
                //if(i<=j && j>0 && j<=n)
                cnt++;
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值