HDU 1060 Leftmost Digit

Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output
For each test case, you should output the leftmost digit of N^N.

Sample Input
  
  
2 3 4

Sample Output
  
  
2 2
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int vis(double n)
{
    double integer;
    double decimal=modf(n*log10(n),&integer);
    double p=pow((double)10,decimal);
    modf(p,&integer);//将整数部分和小数部分分开;
    return (int)integer;
}
int main()
{
    int m,n,i,j,k;
    cin>>m;
    while(m--)
    {
        cin>>n;
        cout<<vis((double)n)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值