NYoj 蛇形填数

描述
在n*n方陈里填入1,2,...,n*n,要求填成蛇形。例如n=4时方陈为:
10 11 12 1
9 16 13 2
8 15 14 3
7 6 5 4
输入
直接输入方陈的维数,即n的值。(n<=100)
输出
输出结果是蛇形方陈。
样例输入
3
样例输出
7 8 1
6 9 2
5 4 3
 
   
#include <iostream>
#include <cstdio>
//#include <cstring>
using namespace std;
int a[100][100];
int main()
{
    int n,x,y;

    int t=0;
    scanf("%d",&n);
    //memset(a,0,sizeof(a));
    t=a[x=0][y=n-1]=1;
    while(t<n*n)
    {
        while(x+1<n&&!a[x+1][y])
            a[++x][y]=++t;
        while(y-1>=0&&!a[x][y-1])
            a[x][--y]=++t;
        while(x-1>=0&&!a[x-1][y])
            a[--x][y]=++t;
        while(y+1<n&&!a[x][y+1])
            a[x][++y]=++t;
    }
    for(x=0; x<n; x++)
    {
        for(y=0; y<n; y++)
            //cout<<left;
            printf("%d ",a[x][y]);//字符右对齐,不足3位数的补空格;
        //cout<<a[x][y]<<endl;
        //cout<<endl;
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值