1010. Zipper

1010. Zipper

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order. For example, consider forming "tcraete" from "cat" and "tree": String A: cat String B: tree String C: tcraete As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree": String A: cat String B: tree String C: catrtee Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line. For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print: Data set n: yes if the third string can be formed from the first two, or Data set n: no if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes
Data set 2: yes
Data set 3: no

题意
◦给定两个单词,如cat和tree,问是否可以通过混合这两个单词来组成指定的单词。
◦设单词1为a1a2a3…an,单词2为b1b2b3…bm,则新单词里面所有ai的相对顺序不能改变,所有bi的相对顺序也不能改变。
◦如指定单词为tcraete,则可以
◦如指定单词为catrtee,则可以
◦如指定单词为cttaree,则不可以


思路
◦二维状态的动态规划
设最终的单词为s3: c0c1c2…cn+m-1
状态:dp[i][j]表示用单词a0a1a2…ai-1和单词b0b1b2…bj-1构成单词c0c1c2…ci+j-1的可能性,其值为1或0。
状态转移: if (dp[i-1][j] && s1[i-1]==s3[i+j-1]) dp[i][j]=1; if (dp[i][j-1] && s2[j-1]==s3[i+j-1]) dp[i][j]=1;
初始值: if (s1[i-1]==s3[i-1]) dp[i][0] = 1; if (s2[j-1]==s3[j-1]) dp[0][j] = 1;



#include<iostream>
#include<cstring>
using namespace std;
int dp[201][201];
int len1,len2,len3;
int main()
{
    int time;
    cin>>time;
    int count=0;
    while(time--)
    {
    string s1,s2,s3;
    cin>>s1>>s2>>s3;
    len1=s1.size();
    len2=s2.size();
    len3=s3.size();
    count++;
    memset(dp,0,sizeof(dp));
    for(int i=0;i<len1;i++)
    {
     if(s1[i]==s3[i])  dp[i+1][0]=1;
     }
     for(int j=0;j<len2;j++)
     {
      if(s2[j]==s3[j]) dp[0][j+1]=1;
      }
      
      for(int i=1;i<=len1;i++)
      {
      for(int j=1;j<=len2;j++)
      {
      if (dp[i-1][j] && s1[i-1]==s3[i+j-1]) dp[i][j]=1;
      if (dp[i][j-1] && s2[j-1]==s3[i+j-1]) dp[i][j]=1;
      }
      }
      
         if(dp[len1][len2]==1)
         cout << "Data set " << count << ": " << "yes" << endl;
         else
          cout << "Data set " << count << ": " << "no" << endl;
          
     }
     //system("pause");
     return 0;
     }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值