Crypto Columns

                                                                              1036. Crypto Columns

Description
The columnar encryption scheme scrambles the letters in a message (or plaintext) using a keyword as illustrated in the following example: Suppose BATBOY is the keyword and our message is MEET ME BY THE OLD OAK TREE. Since the keyword has 6 letters, we write the message (ignoring spacing and punctuation) in a grid with 6 columns, padding with random extra letters as needed:

MEETME
BYTHEO
LDOAKT
REENTH

Here, we've padded the message with NTH. Now the message is printed out by columns, but the columns are printed in the order determined by the letters in the keyword. Since A is the letter of the keyword that comes first in the alphabet, column 2 is printed first. The next letter, B, occurs twice. In the case of a tie like this we print the columns leftmost first, so we print column 1, then column 4. This continues, printing the remaining columns in order 5, 3 and finally 6. So, the order the columns of the grid are printed would be 2, 1, 4, 5, 3, 6, in this case. This output is called the ciphertext, which in this example would be EYDEMBLRTHANMEKTETOEEOTH. Your job will be to recover the plaintext when given the keyword and the ciphertext.

Input

There will be multiple input sets. Each set will be 2 input lines. The first input line will hold the keyword, which will be no longer than 10 characters and will consist of all uppercase letters. The second line will be the ciphertext, which will be no longer than 100 characters and will consist of all uppercase letters. The keyword THEEND indicates end of input, in which case there will be no ciphertext to follow.

Output
For each input set, output one line that contains the plaintext (with any characters that were added for padding). This line should contain no spacing and should be all uppercase letters.
Sample Input
 Copy sample input to clipboard
BATBOY
EYDEMBLRTHANMEKTETOEEOTH
HUMDING
EIAAHEBXOIFWEHRXONNAALRSUMNREDEXCTLFTVEXPEDARTAXNAARYIEX
THEEND
Sample Output
MEETMEBYTHEOLDOAKTREENTH
ONCEUPONATIMEINALANDFARFARAWAYTHERELIVEDTHREEBEARSXXXXXX

题目描述:二维数组转换,根据给出关键词的字母顺序,逆转组合出原来的字符串。

分析:

根据字符串A,可以知道加密时先取哪一列,再取哪一列,于是可以把字符串按顺序填回到矩阵中,最后按从上到下的顺序得到字符串B。

关键词字符串找最小字母:每次比较ASCII值,找到最小后,将其填充为一个比Z还大的字符,以后再对这个字符串找最小的时候,不会再找回这个位置。



#include<iostream>
#include<string>
char note[11][11];
using namespace std;
int min(string k)
{
    int be=-1;
    int min='Z'+1;
    int note;
    for(int i=0;i<k.size();i++)
    {
     if(k[i]<min) 
     {
      min=k[i];
      be=i;
      }
    }
    return be;
}

int main()
{
   string key;
   string s;
   while(cin>>key)
   {
   if(key=="THEEND") return 0;
   cin>>s;
   int len1=key.size();
   int len2=s.size();
   int line;
   line=len2/len1;

   
   int less;
   int a=0;
   for(int x=0;x<len1;x++)
   {
    less=min(key);
    key[less]='a';
    for(int i=0;i<line;i++)
    {
     note[i][less]=s[a];
     a++;
    }
  }
  for(int i=0;i<line;i++)
  {
   for(int j=0;j<len1;j++)
   {
   cout<<note[i][j];
   }
  }
  cout<<endl;
}
//system("pause");
return 0;
}
  
   
   




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值