1001. Common Subsequence

                                   1001. Common Subsequence

Description

 A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm>, another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence(严格递增) <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 

Input

The first line is a positive integer N (1 <= N <= 10000), giving the number of the test cases.

Each test case contains two non-empty strings with length less than 20 representing the given sequences. The sequences are separated by any number of white spaces. 

 

Output

 For each test case, the program prints the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input
3
abcfbc  abfcab
programming  come 
abcd  mnp
Sample Output
4
2
0

题目分析:求两个字符串的最长公共子序列总共有多少个字符。

动态规划:

用dp[i][j]来保存a串第i个字符和b串第j个字符的最大上升子序列,保存的状态为ab串的长度。

如果a[i]=b[j]显然dp[i][j] = DP[i-1][j-1]+1,即在原来的最优解的情况上再+1。

当a[i]!=b[j]时,要看A串的前i-1长度和B串j长度时的最优解,或者A串i长度和B串j-1长度时的最优解,因此得到:DP[i][j]=max{DP[i-1][j],DP[i][j-1]}。

状态转移方程:
    若a[i] = b[j] F[i][j] = F[i-1][j-1] + 1
    若a[i] != b[j] F[i][j] = max(F[i-1][j],F[i][j-1])


#include<iostream>
#include<string>
#include<cstring>
using namespace std;
int dp[1005][1005];
int max(int a,int b,int c)
{
   return  a > b ? a : b;
} 


int main()
{
    int time;
    cin>>time;
    string s1,s2;
    int len1,len2;
    while(time--)
    {
    cin>>s1>>s2;
    len1=s1.size();
    len2=s2.size();
    memset(dp,0,sizeof(dp));
   
    for(int i=1;i<=len1;i++)
    {
     for(int j=1;j<=len2;j++)
     {
      if(s1[i-1]==s2[j-1]) dp[i][j]=dp[i-1][j-1]+1;
      else  dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
      }
    }
    cout<<dp[len1][len2]<<endl;
   }
  
   return 0;
}
    


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值