Partitioning by Palindromes

 Partitioning by Palindromes

We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, 'racecar' is a palindrome, but 'fastcar' is not.

partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, ('race', 'car') is a partition of 'racecar' into two groups.

Given a sequence of characters, we can always create a partition of these characters such that each group in the partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?

For example:

  • 'racecar' is already a palindrome, therefore it can be partitioned into one group.
  • 'fastcar' does not contain any non-trivial palindromes, so it must be partitioned as ('f', 'a', 's', 't', 'c', 'a', 'r').
  • 'aaadbccb' can be partitioned as ('aaa', 'd', 'bccb').

Input begins with the number n of test cases. Each test case consists of a single line of between 1 and 1000 lowercase letters, with no whitespace within.

For each test case, output a line containing the minimum number of groups required to partition the input into groups of palindromes.

Sample Input

3
racecar
fastcar
aaadbccb

Sample Output

1
7
3

题目分析:输入字符串,判断里面最少包含多少个回文字符串;
如:aaa,是一个,abba是一个,abcd是四个,aabbc是三个。
用DP来解。

#include<iostream>
#include<cstring>
using namespace std;

string str;
//char str[1001];
int dp[10000];
int flag;
const int INF=10000;

int main()
{
    int  time;
    cin>>time;
     //scanf("%d",&time);
    while(time--)
    {
      cin>>str;
      const char *a0 = "0"; //在字符串前面添加一个无用字符,填充str[0],方便下面从1开始比较 
      str.insert ( 0, a0 ); 
      int len=str.size()-1;
      
     // scanf("%s",str+1);
      //memset(dp,0,sizeof(dp));//清空 
     
      dp[0]=0;
      for(int i=1;i<=len;i++) //初始化为无穷大 
      {
       dp[i]=INF;
      }
      
      for(int i=1;i<=len;i++)
      {
        for(int j=1;j<=i;j++)
        {
           flag=0;
           for(int k=0;k<=(i-j)/2;k++)
           {
             if(str[i-k]!=str[j+k]) {flag=1;break;};
           }
           
           //if(!flag)    dp[i]=min(dp[i],dp[j-1]+1);
          if(flag==0)  
           {
             if(dp[j-1]+1 < dp[i])  dp[i]=dp[j-1]+1;
           }
        }
      } 
      cout<<dp[len]<<endl;
    }
   // system("pause");
    return 0;
}
      
    


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值