Agri-Net

描述

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.The distance between any two farms will not exceed 100,000.

输入

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

输出

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

样例输入

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

样例输出

28

这道题主要是最短路径的应用, 不过感觉上有点动态规划的感觉 这里面重点在于在已找好的点中找到最短的那条边即权值最小的边,当然出发点是从已找好的点开始的。 因为从一开始更好理解,所以所有下标都从1开始了。

#include<stdio.h>
#include<string.h>
int n, flag[105], dis[105][105], mdis[105], res;
void prim()
{
	int i = 1, j = 1, k = 0;
	memset(flag, 0, sizeof(flag));
	flag[1] = 1;
	
	for (i = 1; i <= n; i++)
	{
		mdis[i] = dis[1][i];	//start with every road's distance
	}
	
	for (i = 1; i < n; i++)//come in (n-1) times
	{
		int min = 100000;//before I take it to the total, so it's wrong, min need to be taken at internal
		for (j = 1; j <= n; j++)// find the least distance at every road 
		{
			if (min > mdis[j] && !flag[j])
			{
				min = mdis[j], k = j;
			}
		}
		
		flag[k] = 1;
		res += min;
		
		for (j = 1; j <= n; j++)// it's important
		{
			if (mdis[j] > dis[k][j]&&!flag[j])// it's from now point's to other point's min distance
			{
				mdis[j] = dis[k][j];
			}
		}
	}
}

int main()
{
	while (scanf ("%d", &n) != EOF)
	{
		int i = 1, j = 1;
		res = 0;
		for (i = 1; i <= n; i++)
		{
			for (j = 1; j <= n; j++)
			{
				scanf ("%d", &dis[i][j]);
			}
		}
		
		prim();
		printf ("%d\n", res);
	}	
	return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值