图 (并查集)2

/*  集合(并查集)
(1)数组的定界是因为不知道第100000个素数的范围
(2)第二个数组的定界是因为sqrt(x)的上界
(3)两个矩阵的乘积,然后初始化,k--,本身有一个,偶数两个矩阵相乘(/2最终为1),奇数一
     个矩阵相乘,求解
题目1444:More is better
题目描述:
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
输入:
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
输出:
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
样例输入:
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
样例输出:
4
2
*/                
#include <stdio.h>
#define N 10000001
int tree[N];
int findroot(int x){//查找结点x所在树的根结点
if(tree[x] == -1) return x;
else{
int tmp = findroot(tree[x]);
tree[x] = tmp;
return tmp;
}
}
int sum[N];//用sum[i]表示以结点i为根的树的结点个数,其中保存数据
//仅当tree[i]为-1即该结点为树的根结点时有效
int main(){
int n,i;
while(scanf("%d",&n) != EOF){
for(i=1;i<N;i++){//初始化结点信息
tree[i] = -1;//所有结点为孤立集合
sum[i] = 1;//所有集合的元素个数为1
}
while(n-- != 0){
int a,b;
scanf("%d%d",&a,&b);
a = findroot(a);
b = findroot(b);
if(a != b){
tree[a] = b;
sum[b] += sum[a];//合并两个集合时,合并后的新树树根累加元素个数


}
}
int ans = 1;//答案至少为1,初始化为1
for(i=1;i<=N;i++){
if(tree[i] == -1 && sum[i] > ans) ans = sum[i];//统计最大值
}
printf("%d\n",ans);//输出
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值