Flip Game

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
 
题目大意:
翻转棋盘,最终使棋盘的颜色为全黑或全白,每次翻转的时候周围上下左右地棋子都要翻转。
解题思路:
由于要每次判断是不是游戏结束,用2维数组存储的话不但存储空间很大,而且也耗时。由于棋子只有黑或白,所以可以用1和0代替b和w。把每一个状态保存为一个数。然后每种状态都有16中操作。要用到队列。还要判断某种状态之前是否出现过,如果出现过,则不进队。BFS 。
#include <stdio.h>
#include <stdlib.h>
#define max 65536
int queue[max*2];
int visit[max];
int step[max];
int main(){
	char color;
	int id=0,tmp;
	int i,j;
	int front=0,rear=0;
//	freopen("input.txt","r",stdin);
	for(i=0;i<4;i++)		//初始化id; 
	for(j=0;j<4;j++){
		scanf(" %c",&color);		//%c前一定要记得加空格。。。 
		id<<=1;
		if(color=='b')	id+=1;		//b代表1(黑), 
	}
	if(id==0||id==65535){
		printf("0\n");
		return 0;
	} 
	queue[rear++]=id;
	visit[id]=1;
	step[id]=0;
	while(front<rear){
		tmp=queue[front++];//出队 
		id=tmp;
		for(i=0;i<4;++i)		//16种操作 
		for(j=0;j<4;++j){
			
			tmp=id;
			if(i==0){
				tmp^=1<<(11-j);
			}
			else if(i==3){
				tmp^=1<<(7-j);
			}
			else{
				tmp^=1<<(11-4*i-j);
				tmp^=1<<(19-4*i-j);
			}
			if(j==0){
				tmp^=3<<(14-4*i);
			}
			else if(j==3){
				tmp^=3<<(12-4*i);
			}
			else{
				tmp^=7<<(14-4*i-j);
			}
			
			//进行一种操作后 
			if(tmp==0||tmp==65535){
				printf("%d\n",step[id]+1);
				return 0;
			}
			if(!visit[tmp]){		//新的状态 
				queue[rear++]=tmp;
				visit[tmp]=1;
				step[tmp]=step[id]+1;
			} 
		}	
	}
	printf("Impossible\n");
	return 0;
} 


 

                
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
pygame.transform.flip() is a method in the Pygame library that is used to flip an image along its axis. This method can be used to create mirror images or to change the orientation of an image. The method takes three arguments: the image to be flipped, a boolean value indicating whether to flip the image horizontally, and a boolean value indicating whether to flip the image vertically. Syntax: ``` pygame.transform.flip(surface, xbool, ybool) ``` - surface: The image to be flipped. - xbool: A boolean value indicating whether to flip the image horizontally (True or False). - ybool: A boolean value indicating whether to flip the image vertically (True or False). Example: ``` import pygame pygame.init() # Set up the display display_width = 640 display_height = 480 game_display = pygame.display.set_mode((display_width, display_height)) # Load the image my_image = pygame.image.load("image.png") # Flip the image horizontally flipped_image = pygame.transform.flip(my_image, True, False) # Display the original and flipped images game_display.blit(my_image, (0, 0)) game_display.blit(flipped_image, (display_width/2, 0)) pygame.display.update() # Quit the game pygame.quit() ``` In the above example, we first load an image using the `pygame.image.load()` method. We then use the `pygame.transform.flip()` method to create a flipped version of the image by passing in `True` as the first argument to indicate that we want to flip the image horizontally. We then display both the original and flipped images using the `blit()` method. Finally, we update the display and quit the game.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值