浙大ACM 1003 Crashing Balloon

这题当时一开始想的很简单,然后碰壁了,后来用递归搞定的。现在拿来看看代码

Crashing Balloon

Time Limit: 2 Seconds      Memory Limit: 65536 KB

On every June 1st, the Children's Day, there will be a game named "crashing balloon" on TV.  The rule is very simple.  On the ground there are 100 labeled balloons, with the numbers 1 to 100.  After the referee shouts "Let's go!"the two players, who each starts with a score of  "1", race to crashthe balloons by their feet and, at the same time,multiply their scores by the numbers written on the balloons they crash. After a minute, the little audiences are allowed to take the remaining balloons away, and each contestant reports his\her score, the product of the numberson the balloons he\she's crashed.  The unofficial winner is the player whoannounced the highest score.

Inevitably, though, disputes arise, and so the official winner is notdetermined until the disputes are resolved.  The player who claimsthe lower score is entitled to challenge his\her opponent's score.  Theplayer with the lower score is presumed to have told the truth, becauseif he\she were to lie about his\her score, he\she would surely come up with a biggerbetter lie.  The challenge is upheld if the player with the higherscore has a score that cannot be achieved with balloons not crashed by thechallenging player.  So, if the challenge is successful, the playerclaiming the lower score wins.

So, for example, if one player claims 343 points and the other claims49, then clearly the first player is lying; the only way to score 343 isby crashing balloons labeled 7 and 49, and the only way to score 49 is by crashinga balloon labeled 49.  Since each of two scores requires crashing theballoon labeled 49, the one claiming 343 points is presumed to be lying.

On the other hand, if one player claims 162 points and the other claims81, it is possible for both to be telling the truth (e.g. one crashes balloons2, 3 and 27, while the other crashes balloon 81), so the challenge would notbe upheld.

By the way, if the challenger made a mistake on calculating his/her score, then the challenge would not be upheld. For example, if one player claims 10001 points and the other claims 10003, then clearly none of them are tellingthe truth. In this case, the challenge would not be upheld.

Unfortunately, anyone who is willing to referee a game of crashing balloon islikely to get over-excited in the hot atmosphere that he\she could not reasonably be expected to perform the intricate calculationsthat refereeing requires.  Hence the need for you, sober programmer,to provide a software solution.

Input

Pairs of unequal, positive numbers, with each pair on a single line, thatare claimed scores from a game of crashing balloon.

Output

Numbers, one to a line, that are the winning scores, assuming that theplayer with the lower score always challenges the outcome.
Sample Input
343 49
3599 610
62 36

Sample Output
49
610
62

#include<stdio.h>
int aa,bb;
void chang(int number1,int number2,int n)
{

 if(number2==1)
   {
     if(number1==1&&bb==1)
       aa=1;
     bb=1;

   }

  if(n>100||(aa==1&&bb==1))
    return ;
 if(number1%n==0){chang(number1/n,number2,n+1);}
 if(number2%n==0){chang(number1,number2/n,n+1);}
  chang(number1,number2,n+1);

}
int main()
{
int n,number1,number2;
while(scanf("%d%d",&number1,&number2)!=EOF)
{
 if(number1<number2)
 {
  n=number1;number1=number2;number2=n;
 }
 aa=bb=0;
 chang(number1,number2,2);

  if(aa==1)
    printf("%d\n",number1);
    else
    {
    if(bb==1)
    printf("%d\n",number2);
    else
    printf("%d\n",number1);
    }
}
return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值