CentOS 7 mysql安装及远程链接

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/u010993471/article/details/80233717

CentOS 7 mysql安装及远程链接

# wget http://repo.mysql.com/mysql-community-release-el7-5.noarch.rpm
# rpm -ivh mysql-community-release-el7-5.noarch.rpm
# yum install mysql-community-server

问题:

Removing mariadb-libs.x86_64 1:5.5.56-2.el7 - u due to obsoletes from mysql-community-libs.x86_64 0:5.6.38-2.el7 - u
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package mariadb.x86_64 1:5.5.56-2.el7 will be an update
---> Package mariadb-libs.x86_64 1:5.5.56-2.el7 will be an update
---> Package mariadb-server.x86_64 1:5.5.56-2.el7 will be an update
--> Processing Dependency: mariadb-server for package: akonadi-mysql-1.9.2-4.el7.x86_64
--> Finished Dependency Resolution
Error: Package: akonadi-mysql-1.9.2-4.el7.x86_64 (@anaconda)
           Requires: mariadb-server
           Removing: 1:mariadb-server-5.5.52-1.el7.x86_64 (@anaconda)
               mariadb-server = 1:5.5.52-1.el7
           Obsoleted By: mysql-community-server-5.6.38-2.el7.x86_64 (mysql56-community)
               Not found
           Updated By: 1:mariadb-server-5.5.56-2.el7.x86_64 (base)
               mariadb-server = 1:5.5.56-2.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

报错原因 :软件包依赖 mariadb组件
解决方案:

#yum -y remove mariadb-libs

再次运行

#yum install mysql-community-server

配置mysql

#service mysqld restart
#mysql -u root
mysql> set password for 'root'@'localhost' =password('your password'); 
Query OK, 0 rows affected (0.00 sec)
mysql> use mysql;
Database changed
mysql> grant all privileges  on *.* to root@'%' identified by "password";
Query OK, 0 rows affected (0.00 sec)
mysql>FLUSH PRIVILEGES;
Query OK, 0 rows affected (0.00 sec)

开机启动

shell> systemctl enable mysqld
shell> systemctl daemon-reload
展开阅读全文

没有更多推荐了,返回首页