poj-1018 Communication System

Communication System
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22369 Accepted: 7950

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices. 
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P. 

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point. 

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649

题目大意:一条联通网络需要由n种设备组成,每种设备可以从不同的供应商处采购,每个供应商提供的不同设备都各有‘带宽’和‘价格’两种属性,现对于第i种设备,有mi个供应商可以提供。

最终组成的联通网络的流量B为网络中最小的设备流量,而最终总花费P为所有设备的价格总和。

显然是B越大、P越小越好。所以求B/P最大可以是多少。


解题思路:

设dp[i][j]为前i件设备带宽为j时的最小花费,

由于P要越小越好,所以初始化dp为近似无穷大。

对于第i种设备,选用第mi个供应商的设备(b,p)时,枚举前i-1种时刻能的带宽k (0<=k<=MB),

1)若k<=b,说明当前设备的选用不会影响到B值,那么此时dp[i][k]=min{dp[i][k],dp[i-1][k]+p}

2)若k>b,说明若选了当前设备,则B就要变为b,那么由此设备推出的就因该是dp[i][b]=min{dp[i][b],dp[i-1][k]+p}

(以上两种情况的的前提都是要dp[i-1][k]有意义


代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cstring>
using namespace std;
const int MB=500;
int dp[120][MB+5];
//dp[i][j]:前i件设备带宽为j时的最小花费
//最终求x/dp[n][x]最大
//
int main()
{
    int num,n,mi,b,p;
	cin>>num;
	while(num--)
	{
		cin>>n;
		memset(dp,120,sizeof(dp));
		int lin=dp[1][1];
		for(int i=1;i<=n;++i)
		{
			cin>>mi;
			for(int j=1;j<=mi;++j)
			{
				scanf("%d%d",&b,&p);
				if(i==1)
				{
					dp[i][b]=min(dp[i][b],p);
				}
				else
				{
					for(int k=0;k<=MB;++k)
					{
						if(dp[i-1][k]!=lin)
						{
							if(k<=b)//此时最小B值不用再变小
								dp[i][k]=min(dp[i][k],dp[i-1][k]+p);
							else//k>b,则最小B值要改为b
								dp[i][b]=min(dp[i][b],dp[i-1][k]+p);
						}
					}
				}
			}
		}
		double ans=-1;
		for(int i=0;i<=MB;++i)
		{
			if(dp[n][i]!=lin)
			{
				double t=(double)i/(double)dp[n][i];
				ans=max(ans,t);
			}
		}
		printf("%.3lf\n",ans);
	}
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值