hdu 1242 Rescue 解题报告

Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13526 Accepted Submission(s): 4947


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........

Sample Output
  
  
13
题目大意 Angel 被押在了监狱里面,他的朋友想去营救他,这个监狱里有守卫人员,用X表示,墙用#表示,.表示通道,a表示Angel的朋友。题目告诉我们这个朋友在过道里每走一步花费一个单位的时间,遇到守卫人员杀掉其需要一个单位时间移走守卫需要1个单位时间,且这个朋友在营救的过程中,只能走到当前位置的上下左右四个方位。最终到达Angel的位置,即r。求最小营救时间。 解题思路 BFS优先队列
解题代码
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <queue>
using namespace std;
char map[205][205];
int vis[205][205];
int m,n;
int d[4][2]= {0,-1,0,1,-1,0,1,0};
struct node
{
    int x,y;
    int time;
    friend bool operator<(const node &a,const node &b)//运算符重载对优先队列里的小于号进行的重载
    {
        return a.time>b.time;//时间小的先出队
    }
};
int bfs(int x,int y)
{
    node st,nt;
    priority_queue<node> q;
    st.x=x;
    st.y=y;
    st.time=-1;
    q.push(st);
    vis[st.x][st.y]=1;
    while(!q.empty())
    {
        st=q.top();
        q.pop();
        if(map[st.x][st.y]=='r')
            return st.time;
        for(int i=0; i<4; i++)
        {
            nt.x=st.x+d[i][0];
            nt.y=st.y+d[i][1];
            if(!vis[nt.x][nt.y] && nt.x>=0 && nt.x<m && nt.y>=0 && nt.y<n && map[nt.x][nt.y]!='#')
            {
                vis[nt.x][nt.y]=1;
                if(map[nt.x][nt.y]=='.')
                    nt.time=st.time+1;
                else
                    nt.time=st.time+2;
                q.push(nt);
            }
        }
    }
    return -1;
}
int main()
{
    int x,y,count;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(vis,0,sizeof(vis));
        count=-1;
        for(int i=0; i<m; i++)
            scanf("%s",map[i]);
        for(int i=0; i<m; i++)
            for(int j=0; j<n; j++)
                if(map[i][j]=='a')
                {
                    x=i;
                    y=j;
                    break;
                }
        count=bfs(x,y);
        if(count==-1)
            printf("Poor ANGEL has to stay in the prison all his life.\n");
        else
            printf("%d\n",count);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值