nefu 677 Gift


Time

Time Limit 1000ms

Memory Limit 65536K

description

  Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.
							

input

  There are several test cases.
  Each case contains 4 integers in a line, separated by space.
  Proceed to the end of file.
							

output

  For each test case, output the time expressed by the digital clock such as Sample Output.
							

sample_input

  1 2 5 6
  2 3 4 2
							

sample_output

   _  _  _ 
 | _||_ |_ 
 ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 
							

hint

  The digits showed by the digital clock are as follows:
     _  _     _  _  _  _  _  _ 
   | _| _||_||_ |_   ||_||_|| |
   ||_  _|  | _||_|  ||_| _||_|
								
							
想当年的时候,这道题用了一个半小时做出来了,用的switch-case语句,现在用同样的方法我用了半个小时搞定,说明我进步了吗~O(∩_∩)O~

还有别的方法请多指教

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;

 int main()
  {
     int n,i,j,k,a[5];
  while(~scanf("%d%d%d%d",&a[0],&a[1],&a[2],&a[3]))
    { for(i=0;i<4;i++)
     {
    switch(a[i])
      { case 2:
        case 3:
        case 5:
        case 6:
        case 7:
        case 8:
        case 9:
        case 0:printf(" _ ");break;
        case 4:
        case 1:printf("   ");break;}}
   printf("\n");
    for(i=0;i<4;i++)
     {
       switch(a[i])
      { case 2:
        case 3:printf(" _|");break;
        case 5:
        case 6:printf("|_ ");break;
        case 7:printf("  |");break;
        case 4:
        case 8:
        case 9:printf("|_|");break;
        case 0:printf("| |");break;
        case 1:printf("  |");break;}}
    printf("\n");
     for(i=0;i<4;i++)
     {
      switch(a[i])
      { case 2:printf("|_ ");break;
        case 9:
        case 3:
        case 5:printf(" _|");break;
        case 8:
        case 6:printf("|_|");break;
        case 7:printf("  |");break;
        case 0:printf("|_|");break;
        case 4:
        case 1:printf("  |");break;}
     }
   printf("\n");



      }




    return 0;
  }




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值