nefu 677 以前真没这样用过,,,

http://acm.nefu.edu.cn/JudgeOnline/problemshow.php?problem_id=677

description

  Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.
							

input

  There are several test cases.
  Each case contains 4 integers in a line, separated by space.
  Proceed to the end of file.

output

  For each test case, output the time expressed by the digital clock such as Sample Output.

sample_input

  1 2 5 6
  2 3 4 2

sample_output

   _  _  _ 
 | _||_ |_ 
 ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_ 

hint

  The digits showed by the digital clock are as follows:
     _  _     _  _  _  _  _  _ 
   | _| _||_||_ |_   ||_||_|| |
   ||_  _|  | _||_|  ||_| _||_|
应用三维字符数组:
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char a[3][10][4]={{" _ ","  "," _ "," _ ","   "," _ "," _ "," _ "," _ "," _ "},
                  {"| |"," |"," _|"," _|","|_|","|_ ","|_ ","  |","|_|","|_|"},
                  {"|_|"," |","|_ "," _|","  |"," _|","|_|","  |","|_|"," _|"}
                 };
int n[5];
int main()
{
    while(~scanf("%d%d%d%d",&n[0],&n[1],&n[2],&n[3]))
    {
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<4;j++)
                printf("%s",a[i][n[j]]);
            puts("");
        }
    }
    return 0;
}
<br /><span id="_xhe_temp" width="0" height="0"><br /></span>
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值