uva 10700 Camel trading

8 篇文章 0 订阅

学习STL有一段时间啦,一直没有做题,今天这题也可以用贪心做,但我借鉴了前辈的思路,

用栈做的,虽然调了一个多小时才调正确了,但还是蛮有成就感的~

 

Camel trading

Time Limit: 1 second

Background

Aroud 800 A.D., El Mamum, Calif of Baghdad was presented the formula 1+2*3*4+5, which had its origin in the financial accounts of a camel transaction. The formula lacked parenthesis and was ambiguous. So, he decided to ask savants to provide him with a method to find which interpretation is the most advantageous for him, depending on whether is is buying or selling the camels.

The Problem

You are commissioned by El Mamum to write a program that determines the maximum and minimum possible interpretation of a parenthesis-less expression.

Input

The input consists of an integer N, followed by N lines, each containing an expression. Each expression is composed of at most 12numbers, each ranging between 1 and 20, and separated by the sum and product operators + and *.

Output

For each given expression, the output will echo a line with the corresponding maximal and minimal interpretations, following the format given in the sample output.

Sample input

3
1+2*3*4+5
4*18+14+7*10
3+11+4*1*13*12*8+3*3+8

Sample output

The maximum and minimum are 81 and 30.
The maximum and minimum are 1560 and 156.
The maximum and minimum are 339768 and 5023.
 
 
#include<iostream>
#include <cstdio>
#include <cstring>
#include<stack>
#include<algorithm>
#include <cmath>
using namespace std;


stack<long long> Max;
stack<long long> Min;

int main()
{
    long long a,tmp,t;

   scanf("%lld",&t);
 while(t--)
 {
   while(!Max.empty())  Max.pop();
   while(!Min.empty())  Min.pop();

    scanf("%lld",&a);
    Max.push(a);
    Min.push(a);
    char ch;
    while(scanf("%c",&ch)&&ch != '\n')
   {

       scanf("%lld",&a);

      if(ch == '+')
      {

         tmp=Max.top();
         Max.pop();
         tmp+=a;
         Max.push(tmp);
         Min.push(a);
         //cout<<tmp<<"**"<<endl;
      }

        if(ch=='*')
      {

          tmp=Min.top();
          Min.pop();
          tmp*=a;
          Min.push(tmp);
          Max.push(a);
          //cout<<tmp<<"&&"<<endl;

      }

   }
  long long sum1=1,sum2=0;
  while(!Max.empty())
  {
      sum1*=Max.top();
      Max.pop();
  }
  while(!Min.empty())
  {
      sum2+=Min.top();
      Min.pop();
  }
 printf("The maximum and minimum are %lld and %lld.\n",sum1,sum2);
 }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值