题目234 吃土豆

http://acm.nyist.net/JudgeOnline/problem.php?pid=234

吃土豆

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
输入
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M,N<=500.
输出
For each case, you just output the MAX qualities you can eat and then get.
样例输入
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
样例输出
242
 
    
 
    
     
     
运行号用户题目结果时间内存语言提交时间
541212
强子唯一吃土豆Accepted7488221java08-13 16:19:59
import java.util.Scanner;

public class Main{
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		while(cin.hasNext()){
			int m =cin.nextInt();
			int n =cin.nextInt();
			int [][]a = new int[m][n];
			for(int i=0;i<m;i++){
				for(int j=0;j<n;j++){
					a[i][j]=cin.nextInt();
				}
			}
			for(int i=0;i<m;i++){
				a[i][1]=Math.max(a[i][0], a[i][1]);
				for(int j=1;j<n-1;j++){
					if((a[i][j+1]+a[i][j-1])>a[i][j]) 
						a[i][j+1]+=a[i][j-1];
					else a[i][j+1]=a[i][j];
				}
			}
			a[1][n-1]=Math.max(a[1][n-1], a[0][n-1]);
			for(int i=1;i<m-1;i++){
				if((a[i-1][n-1]+a[i+1][n-1])>a[i][n-1]) 
					a[i+1][n-1]+=a[i-1][n-1];
				else a[i+1][n-1]=a[i][n-1];
			}
			System.out.println(a[m-1][n-1]);
		}
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
队列传土豆,也叫击鼓传花,是一个经典的游戏,也是一个很好的队列实践题目。 游戏规则是:一群人围成一个圈,开始时一个人手里拿着一个土豆,当音乐响起时,持有土豆的人将其传递给旁边的人,当音乐停止时,手里还拿着土豆的人就要被淘汰,直到最后只剩下一人为止。 这个游戏可以通过队列来实现。首先,将所有人的名字放入一个队列中。然后,将队首的人拿到土豆,再将其传递给下一个人。当传递到一定时间后,将手里拿着土豆的人弹出队列,并将其淘汰。最后,剩下的最后一个人即为游戏的赢家。 下面是Python实现队列传土豆的代码: ```python from collections import deque def queue_potato(names, num): queue = deque(names) while len(queue) > 1: for i in range(num): queue.rotate(-1) # 将队首的人拿到土豆,再将其传递给下一个人 queue.popleft() # 将手里拿着土豆的人弹出队列,并将其淘汰 return queue.pop() # 返回最后一个人 names = ["Alice", "Bob", "Charlie", "David", "Emily"] num = 3 winner = queue_potato(names, num) print("The winner is:", winner) ``` 在这个代码中,我们使用了Python内置的`deque`数据结构来实现队列。`deque`是一个双端队列,可以在队首和队尾进行添加和删除操作。我们使用`rotate`方法将队首的人拿到土豆,再将其传递给下一个人。使用`popleft`方法将手里拿着土豆的人弹出队列,并将其淘汰。最后,我们返回最后一个人作为游戏的赢家。 以上就是Python实现队列传土豆的讲解。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值