Crixalis's Equipment

Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he's a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it's just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

Input

The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.

Output

For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".

Sample Input

2

20 3
10 20
3 10
1 7

10 2
1 10
2 11

Sample Output

Yes
No
 
 
/*
   题意:给定一个体积为V,和N个物品,其中物品有停放体积Ai和移动体积Bi,问
         在给定的体积能否放下这些物品。


   解题报告:写一个排序函数,IF(A1+B2!=A2+B1) return A1+B2<A2+B1
             ELSE  return B1<B2;
             能否全部放下,就看在剩余的空间是否小于下个物品的移动空间。
             如果小于,就不能全部放下,输出No; 否则就继续进行循环,直到循环结束。
             还没输出No,就说明能放下。则输出Yes。


*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;


struct space
{
    int a,b;
}p[1100];


bool cmp(space x,space y)
{
    if((x.a+y.b)!=(x.b+y.a))
   return x.a+y.b<x.b+y.a;
   else return x.b<y.b;
}


int main()
{
    //freopen("a.txt","r",stdin);
    int t,n,v,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&v,&n);
        for(i=0;i<n;i++)
            scanf("%d%d",&p[i].a,&p[i].b);
        sort(p,p+n,cmp);
        for(i=0;i<n;i++)
        {
            if(p[i].b<=v) v-=p[i].a;
            else break;
        }
        if(i==n) puts("Yes");
        else puts("No");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值