画8( HDU - 1256)

A - 画8

 来源:HDU - 1256

Problem Description

谁画8画的好,画的快,今后就发的快,学业发达,事业发达,祝大家发,发,发. 

Input

输入的第一行为一个整数N,表示后面有N组数据. 
每组数据中有一个字符和一个整数,字符表示画笔,整数(>=5)表示高度. 

Output

画横线总是一个字符粗,竖线随着总高度每增长6而增加1个字符宽.当总高度从5增加到6时,其竖线宽度从1增长到2.下圈高度不小于上圈高度,但应尽量接近上圈高度,且下圈的内径呈正方形. 
每画一个"8"应空一行,但最前和最后都无空行. 

Sample Input

2
A 7
B 8

Sample Output

  AA
AA  AA
AA  AA
  AA
AA  AA
AA  AA
  AA

  BBB
BB   BB
BB   BB
  BBB
BB   BB
BB   BB
BB   BB
  BBB

其实应该注意的是第一行B的后边没有空格了,就这一个地方当时没想到,结果一直PE。

代码如下: 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>

using namespace std;

int main()
{
    int n, i, x, j;
    //char s;       // 这里不影响,自己在调试时以为这里出错,其实并没有
    while(~scanf("%d", &n))
    {
        while(n--)
        {
            char s[2];  // 删掉这里,用外边的char s;下边输入%c,后边直接输出%c,s就可以
            getchar();
            scanf("%s %d", s, &x);
            if(x % 2 != 0)
            {
                for(i = 1; i <= x; i++)
                {
                    if(i == 1 || i == x || i == (x + 1) / 2)
                    {
                        for(j = 0; j <= x / 6; j++) printf(" ");
                        for(j = 0; j < (x - 3) / 2; j++) printf("%c", s[0]);
                        printf("\n");
                    }
                    else
                    {
                        for(j = 0; j <= x / 6; j++)
                        {
                            printf("%c", s[0]);
                        }
                        for(j = 0; j < (x - 3) / 2; j++)
                        {
                            printf(" ");
                        }
                        for(j = 0; j <= x / 6; j++)
                        {
                            printf("%c", s[0]);
                        }
                        printf("\n");
                    }
                }
            }
            else
            {
                for(i = 1; i <= x; i++)
                {
                    if(i == 1 || i == x / 2 || i == x)
                    {
                        for(j = 0; j <= x / 6; j++) printf(" ");
                        for(j = 0; j < x - (x / 2) - 1; j++) printf("%c", s[0]);
                        printf("\n");
                    }
                    else
                    {
                        for(j = 0; j <= x / 6; j++)
                        {
                            printf("%c", s[0]);
                        }
                        for(j = 0; j < x - (x / 2) - 1; j++)
                        {
                            printf(" ");
                        }
                        for(j = 0; j <= x / 6; j++)
                        {
                            printf("%c", s[0]);
                        }
                        printf("\n");
                    }
                }
            }
            if(n) printf("\n");
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

WMYBlog

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值