PAT 1101 Quick Sort

https://pintia.cn/problem-sets/994805342720868352/problems/994805366343188480

1101 Quick Sort (25 分)
There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
​5
​​ ). Then the next line contains N distinct positive integers no larger than 10
​9
​​ . The numbers in a line are separated by spaces.

Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5

题目大意:输入一个整数N,接下去输入N个数,求这几个数中,满足左边数都小于它,右边的数都大于它的数,输出这种数的数量,接下去按照升序输出这些数

解题思路:一看到这题就想到了快速排序的思想,分析直接暴力判断每个数是不是要输出的数这样会超时,所以转换一下思路,可以知道快速排序的话,这样作为左右区域大小分割的数是肯定在排好序之后的最终位置上的,所以就另外开一个数组用于把所有的数都排好序,然后和原来的数组进行比较,相同位置上相等的数,就可能是我们要找的数。

这题wa过一次,因为上面说的可能是我们要找的数,我以为就是我们要找的数,直接输出了,这样Pat只能拿16分,还没有考虑到的情况是 41325 ,对于3来说在最终的位置上,但是前面4比它大,所以我们还需要找3前面的最大值是多少,如果比他大,那3就不是我们要找的数,如果比塌小,那肯定是要找的数,因为整个序列比他小的数有 这么多个,全在前面了,后面肯定都是大的。

#include<iostream>
#include<algorithm>
using namespace std;
long long num[100002];
long long num2[100002];
long long ans[100002];
int main()
{
	int n;
	cin >> n;
    for(int i = 0;i<n;i++)
    {
    	cin >> num[i];
    	num2[i] = num[i];
	}
	sort(num,num+n);
	int count = 0,ma = 0;
	for(int i = 0;i<n;i++)
	{
		if(num2[i] == num[i] && num2[i]>ma)
		{
			
			ans[count] = num2[i];
			count++;
		}
		if(ma < num2[i]) ma = num2[i];
		
	}
	cout<<count<<endl;
	for(int i = 0;i<count;i++)
	{
		
			if(i == 0) cout<<ans[i];
			else cout<<" "<<ans[i];
		
	}
	cout<<endl;
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值