HDU 4788 Hard Disk Drive

Hard Disk Drive

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1859 Accepted Submission(s): 1023


Problem Description
  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.

Input
  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.

Output
  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.

Sample Input
  
  
2 100[MB] 1[B]

Sample Output
  
  
Case #1: 4.63% Case #2: 0.00%
Hint

Source





很简单的水题,重点在体会strcmp函数的用途和用法,注意关注一下巧妙的输入代码。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
#include <string>
#include <set>
#include <functional>
#include <numeric>
#include <sstream>
#include <stack>
#include <map>
#include <queue>
using namespace std;
long long solve(char s[])
{//“B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB”
	if(strcmp(s,"B]") == 0)return 0;
	if(strcmp(s,"KB]") == 0)return 1;
	if(strcmp(s,"MB]") == 0)return 2;
	if(strcmp(s,"GB]") == 0)return 3;
	if(strcmp(s,"TB]") == 0)return 4;
	if(strcmp(s,"PB]") == 0)return 5;
	if(strcmp(s,"EB]") == 0)return 6;
	if(strcmp(s,"ZB]") == 0)return 7;
	if(strcmp(s,"YB]") == 0)return 8;
	
}
int main()
{
	long long T;
	cin >> T;
	long long g=1;
	while(T--)
	{
		long long num;
		char s[10000];
		cout<<"Case #"<<g++<<": ";
		scanf("%lld[%s",&num,&s);
		long long n = solve(s);
		printf("%.2f",100*(1-(num*pow(10,n*3))/(num*pow(2,n*10))));
		cout<<"%\n";
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值